none
The RPC server is unavailable (Ox800706BA) RRS feed

  • Question

  • Hi all,

    We will randomly get the agents unavailable and the error is The RPC server is unavailable (Ox800706BA).

    Thw workaround is to reboot the server but we can't reboot our clients server any time we want

    Any ideas are welcome

    Thanks a lot

    RW

    • Moved by Praveen D [MSFT] Thursday, August 26, 2010 6:14 PM Moving to DPM Agent mgmt Forum (From:Data Protection Manager)
    Wednesday, August 25, 2010 11:37 AM

Answers

  • Ruoyu,

    I've seen cases where the DCOMCNFG tool did not display the settings properly and had missing tabs in the GUI at time. It is usually some security settings that do that. However DCOM could still be functioning OK. To see if it is enabled on the box check the following registry value.

    HKLM\Software\Microsoft\Ole
    Name:  EnableDCOM
    Type:  REG_SZ
    Value: Y

    If this value is set to Y then it is enabled. If missing or set to N we need to add/edit the value, set it to Y, and reboot. Check again to make sure the settings stayed set.

    Once DCOM is enabled we can set some additional DCOM logging that will let us know if we are hitting a DCOM permissions/access issue.

    Set these on the protected server we are working on. No reboot is needed.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    Name:  ActivationFailureLoggingLevel
    Type:  DWORD
    Value: 1

    Name:  CallFailureLoggingLevel
    Type:  DWORD
    Value: 1

    This will give us DCOM events in the System and Application event logs. Once we are done we may set these values to zero or leave them on.

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 27, 2010 5:29 PM
    Moderator

All replies

  •  

    1) Check the state of the Remote Procedure Call service on the PS.
    2) Check for DCOM errors in the event logs
    3) Try running wbemtest on a different server and then try connecting to the problematic PS.

    I Believe these three BLOG links cover all the bases for agent communications problems, but the fact that reboot clear it up make me believe it's a dcom service issue.

    http://blogs.technet.com/askcore/archive/2008/05/01/troubleshooting-agent-deployment-in-data-protection-manager-2007-networking.aspx
    http://blogs.technet.com/askcore/archive/2008/04/23/troubleshooting-agent-deployment-in-data-protection-manager-2007.aspx
    http://blogs.technet.com/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 25, 2010 3:40 PM
    Moderator
  • Hi Mike,

    Thank you for your reply. You are right it is a DCOM issue I'm pretty sure.

    I have come cross your third link. However, with no luck. I don't know if you are a DCOM expert. 

    When I looked into the DCOMCNFG, component services, there is a red arrow with "My Computer", and I can't see the full six tabs in the "My Computer Properites". When I restarted the Distributed Transaction Coordinator (MSDTC), sometimes the full tabs would be there, sometimes not.  While I click into the Default Properites, there is a check box "Enable Distributed COM on this computer", if I check it, and apply, the MMC will be crashed.

    Thanks for your help

    Ruoyu

    Thursday, August 26, 2010 2:00 PM
  • Dcom expert I am not, however, look to see if you have any group policy that is disabling dcom - until you get past that, you cannot make progress.
    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, August 26, 2010 6:12 PM
    Moderator
  • Ruoyu,

    I've seen cases where the DCOMCNFG tool did not display the settings properly and had missing tabs in the GUI at time. It is usually some security settings that do that. However DCOM could still be functioning OK. To see if it is enabled on the box check the following registry value.

    HKLM\Software\Microsoft\Ole
    Name:  EnableDCOM
    Type:  REG_SZ
    Value: Y

    If this value is set to Y then it is enabled. If missing or set to N we need to add/edit the value, set it to Y, and reboot. Check again to make sure the settings stayed set.

    Once DCOM is enabled we can set some additional DCOM logging that will let us know if we are hitting a DCOM permissions/access issue.

    Set these on the protected server we are working on. No reboot is needed.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    Name:  ActivationFailureLoggingLevel
    Type:  DWORD
    Value: 1

    Name:  CallFailureLoggingLevel
    Type:  DWORD
    Value: 1

    This will give us DCOM events in the System and Application event logs. Once we are done we may set these values to zero or leave them on.

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 27, 2010 5:29 PM
    Moderator