none
can't receive mail with attachment size less than mail size limit RRS feed

  • Question

  • Sender: private hotmail account. 

    Receiver: exchange 2007 mailbox.

    Setting in exchange 2007:

    1. organization configuration---hub transport--send connectors--maximum message size: 25MB.

    2. server configuration---hub trasport---receive connectors--maximum message size: 10MB.

    3. personal mailbox--message size restriction: null(umlimited)

    symptom:

    1. if i send mail from hotmail to exchange 2007 mailbox with 9MB attachment, the exchange mailbox cant receive mail and hotmail will have a notification mail like below.

    (This message exceeds the maximum message size allowed. Microsoft Exchange will not try to redeliver this message for you. Please make the message smaller -- by removing attachments, for example -- and try sending it again, or provide the following diagnostic text to your system administrator.)

    2. if i send mail from one exchange 2007 mailbox to another exchange 2007 mailbox, it works well.

    Could you please advice? thank you.

    Monday, July 13, 2015 5:41 AM

Answers

  • 1. In some cases, it can take a while (hours) for the change to take effect. Not sure if that applies here specifically. In other cases of changes to quota/max size limits, I've seen it recommended to restart certain services (if that can be done without affecting operations).

    2. At the Organization level, Hub Transport role, what is the limit in Global Settings | Transport Settings?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.


    Monday, July 13, 2015 12:51 PM
  • thank you David, the issue is fixed. :)

    modify the " Global Settings | Transport Settings" and wait for a while, now it works.

    i think there's conversion cost, as i set the max size to 15mb, but only mail less then 11.1mb could be received.

    Tuesday, July 14, 2015 5:55 AM

All replies

  • A message with a 9MB attachment will be larger than 10MB.  Set your limit to 13 or 14MB to be sure you can pass a 9MB attachment.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, July 13, 2015 5:58 AM
    Moderator
  • ED, thank you for the quick reply, :)

    i've changed:

    2. server configuration---hub trasport---receive connectors--maximum message size: 10MB -->25MB.

    and tried an 8.4MB attachment. it still fails.. T_T.

    Monday, July 13, 2015 6:36 AM
  • 1. In some cases, it can take a while (hours) for the change to take effect. Not sure if that applies here specifically. In other cases of changes to quota/max size limits, I've seen it recommended to restart certain services (if that can be done without affecting operations).

    2. At the Organization level, Hub Transport role, what is the limit in Global Settings | Transport Settings?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.


    Monday, July 13, 2015 12:51 PM
  • thank you David, the issue is fixed. :)

    modify the " Global Settings | Transport Settings" and wait for a while, now it works.

    i think there's conversion cost, as i set the max size to 15mb, but only mail less then 11.1mb could be received.

    Tuesday, July 14, 2015 5:55 AM
  • Hi,

    Happy to hear that you have resolve it, you can refer to below link to know the order for message size limitation:
    https://support.microsoft.com/en-us/kb/322679

    Also, here's an article about Understanding Message Size Limits:
    https://technet.microsoft.com/en-us/library/bb124345(v=exchg.141).aspx

    Thanks


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Tuesday, July 14, 2015 6:43 AM
    Moderator