locked
Windows Update: Language Pack (MUI) Install Error RRS feed

  • Question

  • I downloaded my Language Pack via Windows Update.
    The download completed nicely but at the time of the installation, the installation-
    procedure-bar stopped at approximately 90% and fails, announcing me
    Error: code 2
    Screenshot:
    http://img260.imageshack.us/img260/8808/langdr9.jpg

    Would you have a solution or ideas for this problem?
    Thursday, February 1, 2007 9:33 PM

Answers

  • http://support.microsoft.com/kb/925471/en-us

    ... Occasionally, language pack installation fails, and you receive error code 1 or error code 2. This behavior typically occurs when Windows Update has installed another update that has requested a restart. If you experience this issue, restart the computer, and then reinstall the language pack without selecting any other updates. Because of the download size and the installation time that is required to install language packs, we recommend that you only install one language pack at a time ...

    Friday, February 16, 2007 7:35 AM
  • I solved my Problem this weekend with Error 2 (and ErrorCode 0x80070643).

    My BitDefender Internet Security Service was the Problem (Firewall and Anti-Virus)

    Monday, February 19, 2007 9:01 AM

All replies

  • Anyone?
    Even linking me to other sites with the same problem would help me, so please
    try to help me guys :)

    Thanks.
    -Daniel
    Friday, February 2, 2007 4:49 PM
  • I'm having exactly the same problem with the Spanish Language Pack... I managed to install it on a Parallels machine (emulator software under Mac) after rebooting and downloading. Unfortunately while doing a native install on a laptop I've been unable to do so. I've download the package twice and have also tried installing it several times to no avail.

    Let me know if your succesful!!

    Regards

    Sunday, February 4, 2007 9:40 PM
  • where you find the language pack I need an english version because my vista are in german
    mailti:beniamin_igas@yahoo.com
    Tuesday, February 6, 2007 9:23 AM
  • The Language pack is a Windows Ultimate Extra, which means that you only can get it thru windows update in Windows Vista Ultimate Edition.
    Tuesday, February 6, 2007 3:04 PM
  • http://support.microsoft.com/kb/925471/en-us

    ... Occasionally, language pack installation fails, and you receive error code 1 or error code 2. This behavior typically occurs when Windows Update has installed another update that has requested a restart. If you experience this issue, restart the computer, and then reinstall the language pack without selecting any other updates. Because of the download size and the installation time that is required to install language packs, we recommend that you only install one language pack at a time ...

    Friday, February 16, 2007 7:35 AM
  • Hallo, unfortunately that did not solve the problem. The Procedure still fails with error code 2. In Event Viewer there is an Error from WindowsUpdateClient with ID 20 and ErrorCode 0x80070643.

    Any Suggestions?

    Thanks

    Friday, February 16, 2007 9:45 PM
  • I solved my Problem this weekend with Error 2 (and ErrorCode 0x80070643).

    My BitDefender Internet Security Service was the Problem (Firewall and Anti-Virus)

    Monday, February 19, 2007 9:01 AM
  • Did you remove the Security software or you just disabled the Firewal???

    Monday, November 26, 2007 10:32 PM
  • i've downloaded english LP but i can't install it. the installation fails all the time and reboot doesn't give anything. i even tried switching off my anti-virus. nothing works! what should i do?

    Saturday, December 8, 2007 12:54 PM
  • I had the same problems with MUI. Nothing seemed to work.

    After some unsuccessfull hours of Installing SQL-Server I got a hint that the WMI repository of my Vista Ultimate could be corrupt. And this was not only the solution to the SQL Server problems. I tried another installation of the MUI and it worked like a charm.

    The only thing I did was a "winmgmt /salvagerepository" at the command prompt.

     

    Monday, February 4, 2008 6:02 PM
  • Help!  I had the same problem. Language Pack Error 2. No matter which language I try to install. Nothing seemed to work either. I rearched the entire web site, it seemed there is no proper solution for this so far! ... Anyone knows how to fix it? Thanks.

    Saturday, April 12, 2008 7:52 PM
  • Anyone has a solution to this problem?

    In my case, I uninstalled a language pack*; it went ok.  Then when I tried to reinstall it later, I received error 2.  Rebooted and reinstalled again did not work.  *The language pack was the default language of a different user, who was logged off during the language pack's un-installation.

    Installing a different language pack is ok.

    Thanks

    Tuesday, July 27, 2010 3:46 AM