none
User Logoff Notification for Customer Experience Improvement Program RRS feed

  • Question

  • I have a Windows 7 machine here that needs to stay logged on 24/7 due to a program that needs to receive and send files constantly with a remote server.

    We noticed that CEIP would routinely log off and leave the application off, so we disabled it 

    But it's still restarting on a regular basis, and is disrupting our workflow

    Please tell me I'm not the only one with this issue! I could only find threads that were solved by disabling CEIP in the first image, but not ones where it keeps happening even after the disable.

    Thanks in advance for your help!

    Tuesday, September 10, 2013 5:24 PM

Answers

  • Hi,

    I would like to suggest you confirm the CEIP is disabled.

    Disable the Windows Customer Experience Improvement Program

    1.  In the Windows 7 guest operating system, start the control panel and click Action Center > Change Action Center settings.

    2.  Click Customer Experience Improvement Program settings.

    3.  Select No, I don't want to participate in the program and click Save changes.

    4.  Start the control panel and click Administrative Tools > Task Scheduler.

    5.  In the Task Scheduler (Local) pane of the Task Scheduler dialog box, expand the Task Scheduler Library > Microsoft > Windows nodes and open the Application Experience folder.

    6.  Disable the AITAgent and ProgramDataUpdater tasks.

    7.  In the Task Scheduler Library > Microsoft > Windows node, open the Customer Experience Improvement Program folder.

    8.  Disable the Consolidator, KernelCEIPTask, and Use CEIP tasks.

    You may refer to the following link to check it:

    Windows Customer Experience Improvement Program and Resulting Internet Communication in Windows Vista

    http://technet.microsoft.com/en-us/library/cc766341%28v=ws.10%29.aspx

    Please note the section "Procedures for Controlling the Windows Customer Experience Improvement Program".

    Regards,

    Blair Deng

                    

    Blair Deng

    TechNet Community Support

    Wednesday, September 11, 2013 3:12 PM
    Moderator

All replies

  • Hi,

    I would like to suggest you confirm the CEIP is disabled.

    Disable the Windows Customer Experience Improvement Program

    1.  In the Windows 7 guest operating system, start the control panel and click Action Center > Change Action Center settings.

    2.  Click Customer Experience Improvement Program settings.

    3.  Select No, I don't want to participate in the program and click Save changes.

    4.  Start the control panel and click Administrative Tools > Task Scheduler.

    5.  In the Task Scheduler (Local) pane of the Task Scheduler dialog box, expand the Task Scheduler Library > Microsoft > Windows nodes and open the Application Experience folder.

    6.  Disable the AITAgent and ProgramDataUpdater tasks.

    7.  In the Task Scheduler Library > Microsoft > Windows node, open the Customer Experience Improvement Program folder.

    8.  Disable the Consolidator, KernelCEIPTask, and Use CEIP tasks.

    You may refer to the following link to check it:

    Windows Customer Experience Improvement Program and Resulting Internet Communication in Windows Vista

    http://technet.microsoft.com/en-us/library/cc766341%28v=ws.10%29.aspx

    Please note the section "Procedures for Controlling the Windows Customer Experience Improvement Program".

    Regards,

    Blair Deng

                    

    Blair Deng

    TechNet Community Support

    Wednesday, September 11, 2013 3:12 PM
    Moderator
  • Did the above last Friday and so far so good.  thank you Blair Deng
    Monday, September 16, 2013 2:48 PM
  • This is utterly frustrating... I have the same issue; one of my powershell scripts, which happens to take a few hours as it is parsing 100K users in separate domains and exchange servers is continuously being interrupted/logged off because of this. I have done all of the above, but still get:

    "User Logoff Notification for Customer Experience Improvement Program"

    in the system eventlog every few hours, and the logfile my script generates shows me that everything stops exactly at the second of this eventlog entry (event ID 7002). The remote desktop session I used to start the script is gone when this happens.


    This is on a recently installed Server 2012 R2 machine, as I said; CEIP has been disabled, as are all the related tasks, but this logging off -still- happens....!!! It is beyond silly that this is happening because of such a stupid reason (the server is behind firewalls anyway).

    Does anyone know what to do to stop this?

      

    Regards, Paul www.servercare.nl


    Tuesday, May 26, 2015 5:16 PM
  • I am having the same issue, Paul; it appears that randomly, some users sessions are dropped and the System Log have the event ID 7002, "User Logoff Notification for Customer Experience Improvement Program". I have done all of the steps above too. Have you found something to resolve this issue?...thanks in advance!

    Regards, Mike Garcia


    Miguel Garcia - Citrix support

    Thursday, June 25, 2015 1:19 AM
  • Hi Mike,

    I ended up running my script from a service account scheduled as a task. (Which was the better way to do it anyway). No solution to the original problem though, I am sorry to say...


    Regards, Paul www.servercare.nl

    Tuesday, June 30, 2015 6:35 AM
  • Mike,

    The above solution did not help me as well.  I am wondering if you ever found a solution.

    Regards,

    Grif

    Thursday, October 8, 2015 4:59 PM
  • So frustrating!!    How is this not resolved???
    Tuesday, November 10, 2015 1:31 PM
  • Check that inactive "RDP-Sessions" may dropped after 2 days ... "console-sessions" not!

    sample link:

    http://superuser.com/questions/558920/disable-windows-server-2012-automatic-log-off

    Wednesday, October 19, 2016 11:30 AM
  • I am still struggling with this issue. It started happening recently. Anyone found a fix yet ?? I would really appreciate some help.

    Kadir Rangwala

    Tuesday, September 18, 2018 3:32 PM