none
WCF configuration issue.....while accessing the WCF from remote PC RRS feed

  • Question

  • I have Hosted the WCF service whithin IIS 7 on windows 7 box. the WCF service is written in C#.NET using VS 2010 File-->New Project option. I have Windows 7 32 bit edition.

    I am able to browse the Service locally just fine...the XML behind the WSDL file looks just fine. But when i browse that service in remote PC it doesn't work.

    I did followed the complete steps from below article.

    http://debugmode.net/2010/09/07/walkthrough-on-creating-wcf-4-0-service-and-hosting-in-iis-7-5/

    So basically i created Windows project for WCF instead of Website in VS 2010....and followed all the steps to create the service and host in IIS.

    Based on some other inernet articles.....i also disabled the firewall as well.

    Based on the some other internet articles...i also configured Web.config file.

    I also gave my user id the read&Write permission to directory "C:\Source\XXX\" where the project resides. even i publish the website in "C:\inetpub\wwwroot\XXX"..it still the same behaviour.

           

    I also heard rumor that Windows 7 is not meant for developers from few local resources due to not able to configure SMTP on WIndows 7 without third party client.

    Does any one can guide in this environment WCF is possible to make available for remote PCS??

    Please assist as i am too deep into testing this stuff...and all are not complicated...still having basic technical clearance trouble.

     

    Please assit.

    Friday, May 18, 2012 3:38 PM

Answers

  • Respected Community Members,

                                             The issue is resolved......

    There was some settings in the firewall with Windows 7...hosting on IIS 7.

    http://msdn.microsoft.com/en-us/library/ms751530.aspx

    Control Panel->Windows Firewall->Advanced settings->Inbound Rules->Net Rule->port.

    I added that port for WCF for inbound rule and it works like a charm.

    Hopefully this helps community.

    Thanks anyway .

    • Marked as answer by Nicksoft2011 Friday, May 18, 2012 5:41 PM
    Friday, May 18, 2012 5:35 PM