locked
After re-upgrade exchange 2013 cu2 > fails on install MSSpeech_SR_TELE.ca-ES.msi RRS feed

  • Question

  • after re-upgrade Exchange2013-KB2859928-x64-v2.exe

    the setup failed in unexpected state...

    here is the log:

    [07.30.2013 13:20:48.0763] [1] Executing: 
              Add-FirewallException -FirewallRule (New-Object Microsoft.Exchange.Security.WindowsFirewall.MSExchangeDeliveryNumberedPortFirewallRule)
            
    [07.30.2013 13:20:48.0763] [2] Active Directory session settings for 'add-firewallexception' are: View Entire Forest: 'True', Configuration Domain Controller: 'xxx.domain.loc', Preferred Global Catalog: 'xxx.domain.loc', Preferred Domain Controllers: '{ xxx.domain.loc }'
    [07.30.2013 13:20:48.0763] [2] User specified parameters:  -FirewallRule:'Microsoft.Exchange.Security.WindowsFirewall.MSExchangeDeliveryNumberedPortFirewallRule'
    [07.30.2013 13:20:48.0763] [2] Beginning processing Add-FirewallException
    [07.30.2013 13:20:48.0778] [2] Ending processing Add-FirewallException
    [07.30.2013 13:20:48.0778] [1] Processing component 'Speech engine setup' (Configuring the server.).
    [07.30.2013 13:20:48.0778] [1] Executing: 
              Install-MsiPackage `
                -PackagePath ([System.IO.Path]::Combine($RoleLanguagePacksPath, "Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi")) `
                -PropertyValues ("ARPSYSTEMCOMPONENT=1 ALLUSERS=1") `
                -LogFile ([System.IO.Path]::Combine($RoleSetupLoggingPath, "InstallSpeech-ca-ES.msilog"))
            
    [07.30.2013 13:20:48.0778] [2] Active Directory session settings for 'Install-MsiPackage' are: View Entire Forest: 'True', Configuration Domain Controller: 'xxx.domain.loc', Preferred Global Catalog: 'xxx.domain.loc', Preferred Domain Controllers: '{ xxx.domain.loc }'
    [07.30.2013 13:20:48.0778] [2] User specified parameters:  -PackagePath:'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi' -PropertyValues:'ARPSYSTEMCOMPONENT=1 ALLUSERS=1' -LogFile:'C:\ExchangeSetupLogs\InstallSpeech-ca-ES.msilog'
    [07.30.2013 13:20:48.0778] [2] Beginning processing Install-MsiPackage
    [07.30.2013 13:20:48.0810] [2] [ERROR] Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07.30.2013 13:20:48.0810] [2] [ERROR] This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
    [07.30.2013 13:20:48.0810] [2] [ERROR] Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07.30.2013 13:20:48.0810] [2] [ERROR] This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
    [07.30.2013 13:20:48.0810] [1] The following 1 error(s) occurred during task execution:
    [07.30.2013 13:20:48.0810] [1] 0.  ErrorRecord: Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07.30.2013 13:20:48.0810] [1] 0.  ErrorRecord: Microsoft.Exchange.Configuration.Tasks.TaskException: Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619. ---> System.ComponentModel.Win32Exception: This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl)
       at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target)
       at Microsoft.Exchange.Management.Deployment.InstallMsi.InternalBeginProcessing()
       at Microsoft.Exchange.Configuration.Tasks.Task.BeginProcessing()
    [07.30.2013 13:20:48.0810] [1] [ERROR] The following error was generated when "$error.Clear(); 
              Install-MsiPackage `
                -PackagePath ([System.IO.Path]::Combine($RoleLanguagePacksPath, "Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi")) `
                -PropertyValues ("ARPSYSTEMCOMPONENT=1 ALLUSERS=1") `
                -LogFile ([System.IO.Path]::Combine($RoleSetupLoggingPath, "InstallSpeech-ca-ES.msilog"))
            " was run: "Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.".
    [07.30.2013 13:20:48.0810] [1] [ERROR] Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07.30.2013 13:20:48.0810] [1] [ERROR] This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
    [07.30.2013 13:20:48.0810] [1] [ERROR-REFERENCE] Id=SpeechComponent___c2c075b985784599a14e8fa90dbc0403 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
    [07.30.2013 13:20:48.0810] [1] Setup is stopping now because of one or more critical errors.
    [07.30.2013 13:20:48.0810] [1] Finished executing component tasks.
    [07.30.2013 13:20:48.0825] [1] Ending processing Install-MailboxRole
    [07.30.2013 13:20:48.0825] [0] The Exchange Server setup operation didn't complete.  More details can be found in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
    [07.30.2013 13:20:48.0825] [0] End of Setup
    [07.30.2013 13:20:48.0825] [0] **********************************************


    Tuesday, July 30, 2013 2:32 PM

Answers

  • Hi,
    I have seen the same error when an upgrade was run in Windows PowerShell.
    If that was what you did...run the upgrade in CMD with elevated privileges.




    Martina Miskovic

    • Proposed as answer by cara chen Wednesday, July 31, 2013 6:16 AM
    • Marked as answer by cara chen Tuesday, August 6, 2013 9:32 AM
    Tuesday, July 30, 2013 3:13 PM
  • After reply four times in powershell and extract to desktop, it works...

    Many thanks...

    • Proposed as answer by cara chen Wednesday, July 31, 2013 6:16 AM
    • Marked as answer by cara chen Tuesday, August 6, 2013 9:32 AM
    Tuesday, July 30, 2013 6:11 PM

All replies

  • Hi,
    I have seen the same error when an upgrade was run in Windows PowerShell.
    If that was what you did...run the upgrade in CMD with elevated privileges.




    Martina Miskovic

    • Proposed as answer by cara chen Wednesday, July 31, 2013 6:16 AM
    • Marked as answer by cara chen Tuesday, August 6, 2013 9:32 AM
    Tuesday, July 30, 2013 3:13 PM
  • After reply four times in powershell and extract to desktop, it works...

    Many thanks...

    • Proposed as answer by cara chen Wednesday, July 31, 2013 6:16 AM
    • Marked as answer by cara chen Tuesday, August 6, 2013 9:32 AM
    Tuesday, July 30, 2013 6:11 PM
  • I encountered the same error, pointing to the same language pack file - when running setup.exe from an elevated command prompt. I re-downloaded CU2v2 and it worked the second time. Maybe there was a temporary issue with the binary MS published?

    [07/30/2013 17:27:23.0453] [1] Processing component 'Speech engine setup' (Configuring the server.).
    [07/30/2013 17:27:23.0453] [1] Executing: 
              Install-MsiPackage `
                -PackagePath ([System.IO.Path]::Combine($RoleLanguagePacksPath, "Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi")) `
                -PropertyValues ("ARPSYSTEMCOMPONENT=1 ALLUSERS=1") `
                -LogFile ([System.IO.Path]::Combine($RoleSetupLoggingPath, "InstallSpeech-ca-ES.msilog"))
            
    [07/30/2013 17:27:23.0453] [2] Active Directory session settings for 'Install-MsiPackage' are: View Entire Forest: 'True', Configuration Domain Controller: 'xxx.domain.local', Preferred Global Catalog: 'xxx.domain.local', Preferred Domain Controllers: '{ xxx.domain.local }'
    [07/30/2013 17:27:23.0453] [2] User specified parameters:  -PackagePath:'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi' -PropertyValues:'ARPSYSTEMCOMPONENT=1 ALLUSERS=1' -LogFile:'C:\ExchangeSetupLogs\InstallSpeech-ca-ES.msilog'
    [07/30/2013 17:27:23.0453] [2] Beginning processing Install-MsiPackage
    [07/30/2013 17:27:23.0546] [2] [ERROR] Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07/30/2013 17:27:23.0546] [2] [ERROR] This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
    [07/30/2013 17:27:23.0546] [2] [ERROR] Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07/30/2013 17:27:23.0546] [2] [ERROR] This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
    [07/30/2013 17:27:23.0546] [1] The following 1 error(s) occurred during task execution:
    [07/30/2013 17:27:23.0546] [1] 0.  ErrorRecord: Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.
    [07/30/2013 17:27:23.0562] [1] 0.  ErrorRecord: Microsoft.Exchange.Configuration.Tasks.TaskException: Couldn't open package 'C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi'. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619. ---> System.ComponentModel.Win32Exception: This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package
       --- End of inner exception stack trace ---


    Wednesday, July 31, 2013 2:21 PM