Customized Enterprise calendar is not appearing while opening a local project. RRS feed

  • Question

  • Hello Everyone,

    I have customized the default calendar, in which i have added some holidays and change the working time.

    Now I have an .mpp file which I want to save on my project server. For this I open the file in project professional and select my required profile while opening the project professional. Now when I click on the change working time it is not showing me the holidays and custom timing. Whereas when i am selecting any other calendar it is showing me all the holidays in that calendar.

    Now when I try to save the project it is showing me below popup to chose enterprise calendar.

    Why it is not showing me the custom holidays and timings and asking me to select a calendar whereas standard calendar is already associated with it.

    Thanks in advance. 

    • Edited by Shruti Vyas Tuesday, February 23, 2016 1:52 PM
    Tuesday, February 23, 2016 1:38 PM

All replies

  • Shruti --

    When you open the local project (the .mpp file), the local project contains the local Standard calendar in the project.  Microsoft Project DOES NOT replace the local Standard calendar with the enterprise Standard calendar until you attempt to save the project.  When you attempt to save the local project for the first time to Project Server, then the system prompts you to replace the local Standard calendar with the enterprise Standard calendar.

    If you wanted to swap the local Standard calendar with the enterprise Standard calendar before you save the project in Project Server, you can click File > Info > Organizer > Calendar.  Select the Standard calendar on the left side of the dialog (the enterprise Standard calendar) and then click the Copy button to copy it to the local project.  Click the Yes button when prompted to overwrite the calendar.

    Hope this helps.

    Dale A. Howard [MVP]

    Tuesday, February 23, 2016 2:30 PM
  • Thanks Dale for your reply.

    When I tried your solution and open the calendar in Options it is showing me below screen

    And as u can see the copy option is disable. 

    When I tried to Delete/Rename the Standard calendar on right hand side it is showing be below popup

    Now I am unable to find a solution for this.

    Wednesday, February 24, 2016 6:06 AM
  • One problem you have is that every project has a calendar called Standard, so which is the one with the correct non-working times? You have to open it to see. Better to create copies of the Standard calendar and give the copy a useful name. Now you know which calendar is the correct one and it will be easier to copy.

    Go to Project , project Information to select your new calendar for your project.

    Rod Gill
    Author of the one and only Project VBA Book

    Wednesday, February 24, 2016 9:34 AM