locked
VSeWss 1.1: no project templates RRS feed

  • Question

  • Hi,

     

    it would be great if someone here could help me. I posted my problem at the Sharepoint Team Blog as a comment to the Release-Post of VSeWss 1.1, which was not the right place I think. Now, I discovered that a lot of people dicuss such issues in this newsgroup, so thanks to all people sharing their knowledge. 

     

    We used Version 1.0 of VSeWSS for about 4 month and it worked great in our environment. Now I updated to Version 1.1 as prescribed: uninstall V1.0, update Sharepoint and Visual Studio, install V1.1...all completed successfully.

     

    My problem is, that there are no project templates in Visual Studio. Solution Generator works well, but I cannot create a project in Visual Studio, because there are no templates.

    I think the problems is caused by the different language (German Visual Studio !!). I noticed that the folder structure has changed in comparison to V1.0 (subfolder for LCID: Microsoft Visual Studio 8\Common7\IDE\ProjectTemplates\CSharp\SharePoint\1033, in V1.0 it does not exist).

    Version 1.0 was only available in English and works great with a German Visual Studio.

     

    Environment: Win2003 Server R2, WSS SP1, VS 2005 SP1, WSS SKD, VSS Workflow Extensions, VSeWss 1.1

     

    Any help would be great...

     

    Best,

    Martin

    Tuesday, March 4, 2008 9:49 AM

Answers

  • Hi Martin,

     

    We have begun localization for VSeWSS v1.1 and this may have caused your missing templates. A German version is in progress. I'm not certain that's the reason, so please also do a template refresh in Visual Studio. Try these:

     

    devenv /ResetSkipPkgs

     

    or

     

    devenv /InstallVSTemplates

     

    From here.

     

    Regards,

    Paul

    Friday, March 7, 2008 7:16 AM

All replies

  • Is the SharePoint group visible in the list of projects?
    Tuesday, March 4, 2008 10:07 PM
  • Hi,

     

    thank you for your answer.

    Yes, the folder is shown in Visual Studio under Templates, but only workflow templates exist.

     

    Best,

    Martin

    Wednesday, March 5, 2008 6:49 PM
  • Do the extenstion show up in the components list when you open the Help > About window?

    I'd suggest that maybe try re-installing VSeWSS 1.1 and see what happens.
    Wednesday, March 5, 2008 10:07 PM
  • Hi,

     

    yes, the option is shwon in the window:

    Visual Studio 2005 extensions for Windows SharePoint Services 3.0 (version 1.1)

     

    I tried reinstall several times, no luck...

     

    Best,

    Martin

    Thursday, March 6, 2008 1:21 PM
  • Ouch....


    I hope you work on a VM.... Right about now I'd suggest pulling a fresh VM from the shelf and setting up the development environment again.

    Also you should log a bug with the SharePoint team, they'll be interested in this issue.
    Thursday, March 6, 2008 9:31 PM
  • Hi Martin,

     

    We have begun localization for VSeWSS v1.1 and this may have caused your missing templates. A German version is in progress. I'm not certain that's the reason, so please also do a template refresh in Visual Studio. Try these:

     

    devenv /ResetSkipPkgs

     

    or

     

    devenv /InstallVSTemplates

     

    From here.

     

    Regards,

    Paul

    Friday, March 7, 2008 7:16 AM
  • Hi Paul,

     

    that's it. It's so simple...

     

    devenv /ResetSKipPkgs

    Change language folders in "ItemTemplates" and "ProjectsTemplates" from 1033 in 1031 (important!)

    devenv /InstallVSTemplates

     

    no it works. thanks.

     

    Best,

    Martin

    Tuesday, March 11, 2008 11:17 AM