locked
Windows 7 Sleep mode not turning off fan RRS feed

  • Question

  • I have a weird sleep issue that just started, I've built a new PC, Win7x64 and just noticed this happening. When I put the computer to sleep manually, the machine looks like it goes to sleep, but the fans keep running and it 'sounds on'. If I wake the PC, then put it right back to sleep, it goes into deep sleep and the fans go off. Nothing I can see is keeping it awake, I have a i5-2500k, Asus P68 deluxe mobo, and it seems to be a repeatable issue. If the PC wakes up by itself to do something, then goes back to sleep on its own (times out) it goes into deep sleep. It's only when I manually do it that it has the issue. Anyone ever seen this? Thanks!

     

    /curt


    Curt Kessler Franklin Loan Center
    Wednesday, June 8, 2011 6:53 PM

Answers

  • I think it does have something to do with the ASUS AI software, although I have it set for maximum power savings...their tools are, well, badly designed and very difficult to navigate. Have been tinkering in here to see if I can get it to stop.

    Also, I have the machine connected to a Windows Home Server 2011, this may also be the cause, the Launchpad app seems to like to hold open connections. Am still fiddling with each app, have stripped out most of what is always running to see what may be causing this.


    Curt Kessler Franklin Loan Center
    • Marked as answer by Miya Yao Wednesday, July 6, 2011 6:18 AM
    Tuesday, June 21, 2011 1:44 PM

All replies

  • Hi Curt Kessler Franklin,

    Thanks for posting in TechNet forum.

    Please update your BIOS to the latest one, then restart the computer and enter into the BIOS.

    In your Power Management, please choose ACPI S3 sleep mode. It will turn off the fans when go to sleep.

    In addtion, refer to this for the detailed sleep mode information: http://www.sevenforums.com/installation-setup/30124-bios-settings-s1-s3-hybrid-sleep.html

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com  


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 9, 2011 6:20 AM
  • How's going?

    Please feel free to give us any update.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, June 13, 2011 7:49 AM
  • The BIOS is the absolute latest, and yes I have ACPI S3 enabled. It's not a setting that I can see. In fact, the PC has a light on the front that slowly pulses when in standby--and that is definitely on when I put the PC to sleep but the fan keeps going.

    An odd thing that happens is if the PC wakes up, say to record a TV show, when it puts itself to sleep it goes into 'true' deep sleep, fans go off and its silent. It's only when I tell it to sleep that the fans stay on. I've checked all the running programs and devices, and nothing should be keeping it on.

    It's kind of driving me crazy since the PC is in the bedroom and won't be quiet when its time for me to sleep too!


    Curt Kessler Franklin Loan Center
    Monday, June 13, 2011 6:06 PM
  • Hi Curt,

    Thanks for the update.

    When you mentioned "deep sleep", it means hibernation or sleep? They're different.

    Based on your description, the 'sleep' doesn't work when you click Sleep button on the Start Menu, am I right?

    Please check the power settings:

    Control Panel \ Hardware and Sound \ Power Options \ Change plan settings \ Change advanced power settings

    Expand "Power buttons and lid", check the setting of Power button action. Is it Sleep?

    Expand "Sleep", check the time settings under "Sleep after" and "Hibernate after"

    In addition, ensure your hardware devices drivers are up to date.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 14, 2011 5:49 AM
  • When I say 'deep sleep' I mean Sleep, not hibernate. And I have all the correct settings for sleep set, all the buttons are set for sleep. To be clear, and this is why it's frustrating, it's NOT consistent:

    All settings are set for sleep (S3) in BIOS and Windows.
    When I push the Sleep button, the computer looks like it goes to sleep, but fans stay on (NOISY).
    Wake the computer.
    PC Resumes normally.
    Push sleep immediately again, PC goes to sleep, and 1 out of every 3 or 4 times actually goes into true sleep with fans OFF--the way it should. The other times it goes into this kind of half sleep with the fans ON, but all indicator lights on the PC show its asleep.

    Now, if the PC wakes up on its own to record a TV show, it wakes up, records, then goes back to TRUE SLEEP (no fans on). This is consistent, the auto wakeup and back to sleep always results in TRUE SLEEP. 

    I use the PC for a while interactively, push sleep, PC goes to sleep but fans remain on in that kind of half sleep. It just doesn't like it when I wake it up.

    Repeat tries wake up/sleep eventually get the PC into true sleep.


    Curt Kessler Franklin Loan Center
    Tuesday, June 14, 2011 4:59 PM
  • Hi Curt,

    It's really a strange behavior. Did you try a Clean Boot? Refer to: http://support.microsoft.com/kb/929135. Disable non-Microsoft services then check if it works.

    Does this issue occur after you built this new PC? Is this image installed on another PC? Are there something special in your image? It seems really difficult to find the cause of this inconsistant problem.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, June 15, 2011 8:43 AM
  • Yeah, it is inconsistent and weird, which is why its driving me nuts! It is a new PC I built, pretty clean from scratch install but I don't have an image, I just built it interactively. I'm starting to think its some weird interaction with Windows and the UEFI BIOS--its a pretty new board for Sandy Bridge chips and since its on again off again I'm wondering if there is a motherboard level device flaking out, it has an awful lot of new-ish things like bluetooth, USB 3, UEFI that might be setting the system in an inconsistent state.
    Curt Kessler Franklin Loan Center
    Wednesday, June 15, 2011 4:25 PM
  • Hi Curt,

    I susgest you contact Sandy Bridge to check this chips, it seems they have the utility to visual presents the fans speed, temperature and etc. There's nothing I can research anymore on my side, unfortunately.

    I suspect there could be some motherboard issue. Contact their support to find if there's any similar issue about this motherboard model. If your computer is still under warranty, ask the manufacture for a new one.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 16, 2011 8:43 AM
  • Hi Curt,

    Any update yet? Any information from Sandy Bridge?

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 21, 2011 7:56 AM
  • Check ASUS support. It may how the AI by Asus for the motherboard interacts with Windows 7. So, have you installed all of the Asus motherboard controlling applications?
    Tuesday, June 21, 2011 11:00 AM
  • I think it does have something to do with the ASUS AI software, although I have it set for maximum power savings...their tools are, well, badly designed and very difficult to navigate. Have been tinkering in here to see if I can get it to stop.

    Also, I have the machine connected to a Windows Home Server 2011, this may also be the cause, the Launchpad app seems to like to hold open connections. Am still fiddling with each app, have stripped out most of what is always running to see what may be causing this.


    Curt Kessler Franklin Loan Center
    • Marked as answer by Miya Yao Wednesday, July 6, 2011 6:18 AM
    Tuesday, June 21, 2011 1:44 PM
  • As this thread has been quiet a while, there are some hints you've found, and it's hard for us to troubleshoot on our side. I will mark your former reply as answer in order to help other community members who has the similar issue. You can also unmark it if you have any additional information.

    Please directly reply to this thread when you have any update.

    Thanks for your understanding and efforts here.

    Regards,

    Miya

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 6, 2011 6:18 AM
  • I have a weird sleep issue that just started, I've built a new PC, Win7x64 and just noticed this happening. When I put the computer to sleep manually, the machine looks like it goes to sleep, but the fans keep running and it 'sounds on'. If I wake the PC, then put it right back to sleep, it goes into deep sleep and the fans go off. Nothing I can see is keeping it awake, I have a i5-2500k, Asus P68 deluxe mobo, and it seems to be a repeatable issue. If the PC wakes up by itself to do something, then goes back to sleep on its own (times out) it goes into deep sleep. It's only when I manually do it that it has the issue. Anyone ever seen this? Thanks!

     

    /curt


    Curt Kessler Franklin Loan Center

    I had the same issue a while ago. It ended up being because I added my network printer to the printers folder by clicking 'add a network printer' rather than 'add a local printer'.

    When I added a 'local' printer (and pointed it to the IP Address of the printer) the sleep issue went away. Both methods (network/local) were able to print to my network printer, but the network printer option would result in my fans never spinning down. Weird, right?

    -Kramy

    • Proposed as answer by Kramy Monday, January 28, 2013 12:01 AM
    Monday, January 28, 2013 12:01 AM
  • Wow Kramy. Your fix was spot on. I installed a wireless printer a week ago. I was checking all sorts of things on my computer, from my BIOS to my video card. I would have never guessed it was the printer. I wish I could upvote you more. THANKS !!!
    Saturday, April 27, 2013 6:57 AM
  • Just to add on to your info Kramy. (And thanks for connecting the link to the network printer. That was driving me nuts!)

    I had the same problem with the network printer causing the fans not to turn off in sleep mode. You can correct this though. In your power config advanced settings, under sleep, make sure "Enable Hybrid Sleep" is turned on. If the option is not present then at a CMD prompt (run as administrator) type "powercfg -h on" to enable hibernation. Then you should be able to use hybrid sleep. On my computer I was now able to have the network printer device installed and have a complete sleep mode.

    Don't know why... but it worked.


    Saturday, July 6, 2013 8:33 PM
  • Kramy, your solution is as crazy as it is correct. I just confirmed it by adding printer back, sleeping and cringing at the loud fans, then removing the network printer again and enjoying the silent bliss upon sleep. Three times, because I couldn't quite believe it the first time. The crazy is strong with Windows 7. Thanks!
    Thursday, August 29, 2013 5:36 AM
  • Wow, crazy solution Kramy but it worked! Thanks a million! Also noticed there were some intermittancy problems with my external wifi stick associated with the printer problem.
    Saturday, September 14, 2013 7:19 AM
  • THANK YOU!!!! I did not try to remove the network printer I actually do have too ... but.... "Enable Hybrid Sleep" has hallped me on the spot... so far.... ) Many thanks again!!!
    Sunday, November 10, 2013 11:27 AM
  • Thank you Kramy - same issue for me:

    I had to switch the connection of my Epson BX525WD from WLAN to LAN with the result that my Windows 7 x64 system left the fan and keyboard indicators on when entering sleep mode.

    For me it even helped to turn off the printer before entering sleep mode - as an interim solution.

    Wednesday, December 11, 2013 10:25 AM
  • For some motherboards, no solutions will work. My motherboard only supports S1. The fans are always on.

    There is no S3 support.

    Saturday, January 11, 2014 4:45 AM
  • Thanks again as your fix worked for me too. Homebuilt MSI 6303 mb, win8.1,samsung 240gb ssd, HP 6700 premium wireless printer, win8.1

    Grey Avian

    Tuesday, February 18, 2014 12:14 AM
  • I just dealt with the same kind of issue; sleep suddenly stopped working as it had worked prior to me updating my BIOS.  The fix for me was to set my BIOS to accept S3 only (not S1 and not 'auto'), and set my Windows 7 Power Configuration options like:

    *Allow Hybrid Sleep=ON

    *Allow Wake Timers=DISABLED

    *USB Selective Suspend Setting=ENABLED

    Now my Desktop finally sleeps like it used to, all fans and power supply off but it jumps back to life and gives me my display in about 2 seconds.

    Sudz

    Monday, March 6, 2017 10:14 PM
  • I've had this issue for quite some time now and reading this post I tried :

    *Allow Wake Timers=DISABLED  (it was ENABLED before)

    It fixed my problem immediately.

    My PC is set to Sleep only, no Hybrid. My FAN problem started some time ago, maybe 6 to 9 months. Probably an update from MS. The Bios is quite old and no BIOS update are available. Anyway, the fans were shutting down properly before it all started so it couldnt be a BIOS issue.

    Now that Allow Wake Timer is disable, the fans are shutting down properly. Thinking about it, it may be an updated behavior which could be viable. If the computer is set on some kind of obligatory monitoring of waking up at a set time, the CPU must work to monitor that programmed wake-up call. Hence heat a little. So the fan must be keeped ON to cool down the process. Even though the PC is somewhat "sleeping".

    Anyhow, it works now. Hope this will help someone else.  Cheers

    Thursday, July 5, 2018 4:02 PM