locked
connot reinstall agent on a DC RRS feed

  • Question

  • We are running SCCM 2012 SP1.

    The SCCM agent on a DC was not working. From the ccmsetup.log it seems that the agent was trying to reinstall itself and failing. I uninstalled the agent and pushed the agent; nothing seemed to happen.

    I tried to manually install the agent. I found this error “Setup was unable to compile the file DiscoveryStatus.mof The error code is 8004100E”. I fixed it by running ”mofcomp ExtendedStatus.mof”.

    The agent then did install. However, the agent did not connect to Configuration Manager. The connection is open between the two.

    Any idea on why Configuration Manager will not install the agent?

    Thursday, November 14, 2013 9:24 PM

Answers

  • ClientIDManagerStartup.log shows an error:

    GetSystemEnclosureInfo failed (0x80041010) ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)
    ComputeHardwareID failed (0x80041010). ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)
    RegTask: Failed to create registration request body. Error: 0x80041010 ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)

    So the client cannot be registered. 0x80041010 = invalid class (WMI).

    It *might* be possible that WMI has got issues on the DC.


    Torsten Meringer | http://www.mssccmfaq.de

    • Proposed as answer by Joyce L Monday, November 18, 2013 7:18 AM
    • Marked as answer by Carl M5646813 Tuesday, November 19, 2013 12:35 AM
    Friday, November 15, 2013 7:14 PM

All replies

  • Was the installation successful according to ccmsetup.log?
    Have you already examined client side logfiles like ClientIDManagerStartup.log, LocationServices.log, ClientLocation.log. ccmmessaging.log?

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, November 14, 2013 9:32 PM
  • installation was successful

    ClientIDManagerStartup.log

    Failed to submit event to the Status Agent. Attempting to create pending event. ClientIDManagerStartup 11/14/2013 3:38:23 PM 2104 (0x0838)
    
    RegTask: Failed to refresh MP. Error: 0x80004005 ClientIDManagerStartup 11/14/2013 3:38:26 PM 5988 (0x1764)
    
    RegTask: Failed to refresh MP. Error: 0x80004005 ClientIDManagerStartup 11/14/2013 3:43:26 PM 5988 (0x1764)
    

    The ClientLocation.log has no errors

    LocationServices.log

    Failed to send management point list Location Request Message to bisque.ad.northcentral.edu LocationServices 11/14/2013 3:53:42 PM 5472 (0x1560)
    
    Failed to CoCreate CcmMessaging LocationServices 11/14/2013 3:53:42 PM 5472 (0x1560)
    

    LocationServices.log

    Successfully sent location services HTTP failure message. CcmMessaging 11/14/2013 3:38:18 PM 5384 (0x1508) 
    
    Post to http://name/ccm_system/request failed with 0x87d00231. CcmMessaging 11/14/2013 3:38:18 PM 5384 (0x1508)
    

    CcmExec.log

    Failed to read WMI performance counter classes. Idle detection may not consider disk I/O if the issue persists. CcmExec 11/14/2013 3:38:23 PM 2104 (0x0838)
    
    Error processing notification query for endpoint 'EndpointProtectionAgent'. Query='wqlns:root\cimv2:select * from __instancecreationevent within 60 where targetinstance isa "win32_service" and targetinstance.name="msmpsvc"'. Code =0x80041010 CcmExec 11/14/2013 3:38:24 PM 5028 (0x13A4)
    
    Failed to read WMI performance counter classes. Idle detection may not consider disk I/O if the issue persists. CcmExec 11/14/2013 3:53:42 PM 3300 (0x0CE4)
    
    Failed to open to WMI namespace '\\.\root\ccm\Policy\Machine' (8007045b) CcmExec 11/14/2013 3:57:29 PM 3500 (0x0DAC)
    
    Could not connect to machine policy WMI namespace to get service settings. CcmExec 11/14/2013 3:57:29 PM 3500 (0x0DAC)
    

    SrcUpdateMgr.log

    Instance of CCM_SourceUpdateClientConfig doesn't exist in WMI           SrcUpdateMgr  11/14/2013 3:38:22 PM  5384 (0x1508)
    
    Failed to get instance of CCM_SourceUpdateHistory, error 80041002      SrcUpdateMgr  11/14/2013 3:38:22 PM  5384 (0x1508)
    

    StatusAgent.log

    Registration failed with error 0x80041010              StatusAgent       11/14/2013 4:02:45 PM  5420 (0x152C)
    
    Failed to add event forwarder for CCM_EVENTFORWARDER_CONFIGURATION.INSTANCEID="SMSBRANCHDP.INSTANCE0",NAME="SMSEVENTLOGFORWARDER"                StatusAgent       11/14/2013 4:02:45 PM  5420 (0x152C)
    

    Thursday, November 14, 2013 10:24 PM
  • Just posting errors or warnings that are taken out of context does not help at all. Please upload the logs to Skydrive.

    Torsten Meringer | http://www.mssccmfaq.de

    Friday, November 15, 2013 8:08 AM
  • ClientIDManagerStartup.log shows an error:

    GetSystemEnclosureInfo failed (0x80041010) ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)
    ComputeHardwareID failed (0x80041010). ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)
    RegTask: Failed to create registration request body. Error: 0x80041010 ClientIDManagerStartup 15.11.2013 09:14:12 5500 (0x157C)

    So the client cannot be registered. 0x80041010 = invalid class (WMI).

    It *might* be possible that WMI has got issues on the DC.


    Torsten Meringer | http://www.mssccmfaq.de

    • Proposed as answer by Joyce L Monday, November 18, 2013 7:18 AM
    • Marked as answer by Carl M5646813 Tuesday, November 19, 2013 12:35 AM
    Friday, November 15, 2013 7:14 PM
  • That is what I have come to suspect as well. I have now found other things that use WMI, are not working either.

    Friday, November 15, 2013 8:53 PM
  • I re-register the DLLs and recompile the mofs. This seems to have fixed the issue with the Configuration Manager agent and the HP WBEM tools.

    • Proposed as answer by TorstenMMVP Tuesday, November 19, 2013 8:50 AM
    Tuesday, November 19, 2013 12:34 AM