none
immediately after the reboot requested by bitlocker activation the recovery console does not accept the recovery key but the data is not encrypted yet RRS feed

  • General discussion

  • I activated bitlocker, it goes through the questions I chose the new W10 only version for the entire disk as it was not a new system, I tick the test and it asks for a reboot telling the the encryption will start after the reboot.

    I reboot and the machine shows the bitlocker recovery console asking for the recovery key. I enter the key, it does not tell that the key is wrong, but it tells "failed to unlock with this recovery key" but the given ID is correct for the newly generated key which I printed and saved, so that the key cannot be wrong.

    I have gone through many problem reports, where the data was actually encrypted until I thought that the issue must be another, my data was not encrypted yet as the system never booted after activating BL. I tried M3 bitlocker recovery with the key, which it accepted, but it didnt find any files(with a different key it told that the key was wrong, another confirmation that my key is the right one)

    Than I used Hasleo to do a raw recovery and it found a damaged partition als all of my files, so guessing that they where not encrypted yet was correct. bitlocker has only marked the drive as encrypted but something went wrong before the encryption actually started. I will sleep better tonight, but I would like to understand what happened. And there must be a way to fix it(bit flicking the few bits that tell that the drive is encryped while it is not.)

    For better reproducability I will describe what happend to get into that trouble. 

    I had one software that didnt work correctly on my surfacebook2, we debuged the issue to a point where only a clean install could tell if the prog would run on a surfacebook2 or not. So I disabled bitlocker and unencrypted my disk to be able to shrink the partition to get free space for a second partition with a second W10 installation. once the ne installation was up and running the software that caused headaches on the original micosoft preinstalled W10 worked perfectly in the new installation. So that I knew that I would have to migrate my stuff from the MS intall to my own, erase the intial partition, and move and resize the new installation.

    In the meantime, as all my confidential data was still on the old c: I thought it might be a good idea to reactivate bitlocker on that installation and I did not expect to run into trouble as it worked before but it proved me wrong, the rest of the story is in the beginning of this post.

    Thank you in advance for any hints, i am looking for:

    why did this happen

    how could I fix it (not the real problem anymore as the important data is recovered)

    And what could MS do to prevent this from happening

    Sunday, November 25, 2018 12:36 AM

All replies

  • Fortunately, your data has been recovered, it’s good.

    What I think is your hardware configurations, because BitLocker recovery mode will only be enabled when device changes hardware, install major updates/upgrade, change BIOS settings, change firmware or other big operations. Normally enable BitLocker will not reboot, not to mention enter recovery mode.

    In my opinion, you’d better backup your important data, re-arrange disk storage(you have done will now) reinstall system completely, finally, consider enabling BitLocker via Control Panel.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 26, 2018 8:37 AM
    Moderator