none
SQL Agent Log Shipping Backup job fails occassionally

    Question

  • Hello,

        It's been noticed that SQL Agent Log Shipping job for one or more databases fails occasionally with the reason as below

     Executed as User:XXXX The process could not be created for step 1 of job 0x5A6FFE1F473882B40ADFA0ED12068777B (reason: 5).  The step failed.

    On it's next run it goes well without any failure, As it doesn't show up any reason beyond the above I am unable to get what really went wrong. What does Reason 5 states?

    Have googled a lot but not able to find the explanation for reason 5.

    thanks

    Mohan

    Thursday, May 17, 2018 5:35 AM

All replies

  • did you have a look at Event log?

    Any errors in it?


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Thursday, May 17, 2018 5:54 AM
  • Hi Visakh,

         I checked even log for that time of failure and found the below Error Message for SQL server, It looks its related to Backup failure. Please check and let me know. Also note I have anonymized the data for security purposes.

    CN=ServerNode1,OU=XXX,OU=APP,OU=DXX,DC=XXX,DC=XX,DC=XX,DC=com

    Backup Operators; Enforced
    Backup Operators; Domain1\ADMS_SRVC_ActiveNode_Backup; Already member
    Backup Operators; Domain1\ADMS_SRVC_ActiveNode_Backup; Already member

    Power Users; Enforced
    Power Users; Domain1\ADMS_SRVC_APPS-XEU_Power; Already member
    Power Users; Domain1\ADMS_SRVC_Apps_Power; Already member

    Administrators; Enforced
    Administrators; Domain1\<Service account of SQL Server>; Member excluded
    Administrators; Domain1\-svc-appz2-xxx-sql; Member excluded
    Administrators; Domain1\ADMS_SRVc_HTT-xxx-xxx_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMS_SRVc_HTT-xxx-xxx_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMS_SRVc_HTT-xxx-xxx_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMs_SRVc_HTT-XXXX-XMW_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMs_SRVc_HTT_Node1_Admin; Already member
    Administrators; Domain1\ADMS_SRVC_APPS-xxx_Admin; Already member
    Administrators; Domain1\ADM_SRV_HP-xxx-xxx-xxx_Admin; Excluded member not found in local group
    Administrators; Domain1\Domain Admins; Already member
    Administrators; Domain1\ADMs_SRVc_HP-xxx-xxx-XTX_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMs_SRVc_xxx-xxx_Admin; Excluded member not found in local group
    Administrators; Domain1\ADMs_SRVc_xxx-xxx-xxx_Admin; Member excluded
    Administrators; Node1\BPGDB_administrator; Member excluded

    Event Log Readers; not Enforced
    Event Log Readers; NT AUTHORITY\NetworkService; Add/Remove failed, unspecified  error
    Event Log Readers; Domain1\-xxx-xxx-xxx-PRODDB; Non policy member
    Event Log Readers; NT AUTHORITY\NETWORK SERVICE; Non policy member

    Remote Desktop Users; not Enforced
    Remote Desktop Users; Domain1\ADMS_SRVC_Node1_Power; Already member
    Remote Desktop Users; Domain1\ADMS_SRVC_Node1_Backup; Already member

    thanks

    Mohan

    Thursday, May 17, 2018 6:33 AM
  • Seems like some issue with service account running SQL Server agent, somehow it is loosing its a access to AD or in other terms the account verification is failing intermittently. I am not sure I have used correct words here but superficially this is happening. 

    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Thursday, May 17, 2018 6:58 AM
    Moderator