none
Disable screen saver from registry? RRS feed

  • Question

  • I have a problem with a MS Surface Pro running Windows 10 Build 1809. It is a company surface so it has a lot of GPO's attached. We are trying to disable the screen saver lock via GPO, but it is not working. Right now I am trying to disable it via registry. Setting the screen saver settings from GUI is disabled. Local policies are not configured. I have tried everything I can find on the internet, nothing seems to work. I can change the settings in registry, but it seems they need a restart or log off/in to register properly. The problem is then they are reverted back to the previous values.

    Current values:

    ScreenSaveActive = 1

    ScreenSaverIsSecure = 1

    ScreenSaveTimeOut = 900

    SCRNSAVE.EXE points to logon.scr

    I have local admin, but I don't have access to setting GPO's at the moment.

    Any tips would be appreciated.

    Saturday, October 5, 2019 12:34 PM

All replies

  • Let us start with the GPO settings:

    Log in as Administrator

    Type Gpedit.msc and hit the Enter Key.

    Now locate:

    User Configuration > Administrative Templates > Control Panel > Personalization. Double-click on the policy labeled “Enable screen saver“.

    Set it to Disabled if you want to turn off screen saver. After disabling, all the screen saver settings options will be greyed out.

    Via Registry:

    To disable the logon screen saver, follow these steps:
    1. Click Start, click Run, type regedt32, and then click
      OK.
    2. Locate the following registry key:
      HKEY_USERS\.DEFAULT\Control Panel\Desktop
    3. In the Details pane, double-click the
      ScreenSaveActive string value item.
    4. In the Value data box, replace the number 1 with the number 0, and then click OK.
    You have now disabled the logon screen saver.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Sunday, October 6, 2019 12:29 AM
  • This did not help. I did not have the ScreenSaveActive under HEY_USERS, so I added it, but it did not do anything. The position that seems to be overwritten by global policy is HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop

    I did a GPresult report and it seems as if these settings are controlled by a global policy and not a local policy. I will contact my domain admin tomorrow. I will report back what we find.

    Sunday, October 6, 2019 9:03 AM
  • Yes, you have done the right thing.

    For domain-joined PC, DC global policies will overwritten local policies and corresponding registry values, unless we leave domain or disconnect domain network.

    Contact your DC admin and tell them your situation, let them come up with a compromise.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 7, 2019 2:43 AM
    Moderator
  • My Domain admins were able to disable the screensaver via Global Policy. The problem now is that it is user settings. And I want this setting to apply only to certain computers in the domain, not every computer I log on to. Any suggestions on how to fix that?

    Tuesday, October 8, 2019 9:22 AM
  • You need to open a new case for your demand. Maybe you DC admin can set specific OU that applied those settings

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 6, 2019 9:20 AM
    Moderator