locked
Single-sign on not working - unknown user RRS feed

  • Question

  • Hi. I'm trying to configure SSO for 2012 R2 AppController.

    I've followed the steps in https://technet.microsoft.com/en-us/library/gg696046#sectionSection1

    When I go to the AC portal, I'm automatically logged on, but it says "unknown user" instead of my domain name and I cannot access the VMs and clouds etc.

    Any ideas how to fix that?

    What I've done:

     - configured Windows authentication (and disabled basic) on the /api portion of the AC website per documentation

     - configured constrained delegation on the AC domain machine account (added the domain user under which HA VMM R2 service is running - this offered me the HA VMM computer name  - which I've added), then added cifs service for the HA VMM computer name per documentation

     - tried restarting the server where AC is running several times

     - tried adding Negotiate:Kerberos provider in the providers settings of the "Windows Authentication" setting (which had me disable the "Enable Kernel-mode authentication" setting

    None of the above worked.

    Friday, December 4, 2015 4:26 PM

All replies