none
Force RDP to connect in full screen mode RRS feed

  • Question

  • Hello there,

    I have about 60 servers that I manage remotely using RDP from the office and from home.

    At the office I have a 19" screen with max resolution of 1280X1024 and at home I have 20" wide screen with max resolution of 1650X1050.
    When I work from the office, I have no issues. When I work from home, I first VPN into my machine at the office and then RDP to the different servers. After working from home and going back to the office, RDP opens in a 640X480 resolution and that produces horizontal and vertical scoll bars and I need to adjust it multiple times until it holds for all servers. If I work from home this happens again.

    is there a registry setting that I can force RDP to always start in full screen regardless of resolution used? I've been googling it for a little while and came up with nothing.

    I am using Windows Vista Business 32bit with RDP v6.0 at the office and Windows 7 Ultimate 64bit with the original RDP client at home, if that makes any difference.

    Thank you,

    Wednesday, September 15, 2010 1:51 PM

Answers

All replies

  • Hi,

    Have you tried to change the resolution in MSTSC.exe? You can click Options, go to Display tab, change the Display configuration to right as set to "Full Screen".

    Also you can set the screen mode id value to 2 and deploy the RDP file.

    http://technet.microsoft.com/en-us/library/ff393692(WS.10).aspx

    Thanks,

    Shaon Shan

     

     


    Shaon Shan| TechNet Subscriber Support in forum| If you have any feedback on our support, please contact tngfb@microsoft.com
    Thursday, September 16, 2010 7:49 AM
    Moderator

  • I have exactly the same problem. If RDP detects that the monitor you are currently connecting with is a smaller size than that you last connected with it scraps the Full Screen setting and goes with the small screen size and puts it in a window which is completely useless because the windows key does not work as it does in full screen mode and also who wants to use scroll bars with an RDP connection to let you click on the start button??? really not user-friendly and i have to close then connection start a new RDP connection and check the screen settings every single time which is really not productive.

    What I would like to see is that if you select Full screen it will always be full screen and will NOT remove the full screen option to give windowed mode.

    Also it would be great if I can force full screen as default for all new RDP connections.

     I feel for you arie01 having 60 servers. It is not that bad for me because I only have about 10 to deal with!
    Thursday, April 25, 2013 9:08 AM
  • You can pin it to your taskbar. Then right click on it. Then right click on Remote Desktop Connection just above Unpin from Taskbar and choose properties. Add /f switch to the executable and click OK. It will always default to full screen when open from the taskbar. If you have that many servers you probably just change type the server prefix instead of having shortcuts , Cheers
    • Proposed as answer by UdayReddy Wednesday, January 13, 2016 5:46 PM
    Saturday, April 11, 2015 12:39 PM
  • /f worked.

    Thank You.

    Saturday, May 25, 2019 9:58 PM
  • No Registry setting that I'm aware of offhand, but you can always edit your Default.rdp file. It's in your Documents folder by default.  There's a "screen mode" setting... 2 for full screen:

    screen mode id:i:2        <= full screen

    screen mode id:i:1        <= window

    Wednesday, September 18, 2019 4:10 PM