locked
How to stop windows 7 from snapping in two columns? RRS feed

  • Question

  • I did something so that my windows keeps snapping things two either the left or right virtual column on my desktop.  I can't figure out how to stop that. I have disabled the snap to under the "make my mouse easier to use" section in control panel.  Please help. This is driving me crazy.
    Saturday, January 23, 2010 10:11 PM

Answers

  • That checkbox for 'Prevent windows from being automatically arranged when moved to the edge of the screen' should have worked.  There are three places in the Control Panel that offer this setting (you should only have to use one of these methods.

       Option 1:  Control Panel > Ease of Access Center > Make the Mouse Easier to Use
       Option 2:  Control Panel > Ease of Access Center > Make the Keyboard Easier to Use
       Option 3:  Control Panel > Ease of Access Center > Make it Easier to Focus on Tasks


    Let's now use Registry Editor to check that the setting is being applied successfully:

       1 - Type regedit into the Start menu, then press Enter.  If prompted, confirm the action.
       2 - Using the folders on the left, navigate to HKEY_CURRENT_USER > Control Panel > Desktop
       3 - In the right side, check the value of the WindowArrangementActive item.  It should be 0 (zero) for disabled.

    If you need to change it, double click the WindowArrangementActive item, and type a 0 (zero) into the form.  Then click OK, close Registry Editor, and reboot your computer.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!

    Use caution, as editing some important parts of the registry could leave your computer unable to start. As a general rule, do not edit the registry unless you are confident of the impact.
    Monday, February 1, 2010 3:22 AM

All replies

  • The option you mentioned should have done it.  Can you go back there and make sure that it is still set correctly?  Perhaps it did not save your preference when you closed the window.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Saturday, January 23, 2010 10:44 PM
  • I did make sure. I have even rebooted. I remember when I did it, I somehow had the option to choose a layout for my screen.  I just don;t know where that was.
    Saturday, January 23, 2010 11:03 PM
  • Hi SLevine,

     

    Please go to Start, type snap in the Start Search box and then press ENTER. Check "Prevent windows from being automatically arranged when moved to the edge of the screen" and then click OK.

     

    Please check if the issue can be resolved now.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Monday, February 1, 2010 3:00 AM
    • Unmarked as answer by SLevine Monday, February 1, 2010 3:01 AM
    Monday, January 25, 2010 8:13 AM
  • This option is checked, but it does not stop the issue :(
    Monday, February 1, 2010 3:01 AM
  • That checkbox for 'Prevent windows from being automatically arranged when moved to the edge of the screen' should have worked.  There are three places in the Control Panel that offer this setting (you should only have to use one of these methods.

       Option 1:  Control Panel > Ease of Access Center > Make the Mouse Easier to Use
       Option 2:  Control Panel > Ease of Access Center > Make the Keyboard Easier to Use
       Option 3:  Control Panel > Ease of Access Center > Make it Easier to Focus on Tasks


    Let's now use Registry Editor to check that the setting is being applied successfully:

       1 - Type regedit into the Start menu, then press Enter.  If prompted, confirm the action.
       2 - Using the folders on the left, navigate to HKEY_CURRENT_USER > Control Panel > Desktop
       3 - In the right side, check the value of the WindowArrangementActive item.  It should be 0 (zero) for disabled.

    If you need to change it, double click the WindowArrangementActive item, and type a 0 (zero) into the form.  Then click OK, close Registry Editor, and reboot your computer.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!

    Use caution, as editing some important parts of the registry could leave your computer unable to start. As a general rule, do not edit the registry unless you are confident of the impact.
    Monday, February 1, 2010 3:22 AM
  • I have the same problem. I've followed the steps you mentioned above, changed the value to 0, and also checked the option "Prevent windows from being automatically arranged when moved to the edge of the screen " as Linda suggested above. I reboot the laptop, problem is still there~~~ I double checked the settings. They are all fine! Now I don't know what to do. Any suggestions?
    Saturday, November 6, 2010 9:30 PM