SharePoint 2010 Workflow Initiation forms generate as ASPX rather than Infopath XSN RRS feed

  • Question

  • I recently migrated a SharePoint Team site from our dev to our production environment (SP 2010 Enterprise). Now, whenever I create a workflow using SharePoint Designer, the initiation form generates as an ASPX file rather than an Infopath XSN file. So, whenever I try to manually run the worflow using the "Start" button, the form doesn't close after running the workflow.

    I checked to make sure the site collection features are the same. When I create a new list (not migrated), then create a workflow within it, the initiation form is also ASPX. However, if I create a subsite - then a list and workflow on that subsite - the initiation forms there show up as XSN.

    I've looked around on the forums and google, but can't find a way to force the forms to display as ASPX or to change them to XSN from ASPX.

    I can submit screenshots or any other details that might help figure out what's going on.

    Thursday, July 12, 2012 3:34 PM

All replies

  • Does anyone have any ideas?
    Monday, July 16, 2012 7:41 PM
  • I have the exact opposite issue. I need the initiation page to be .ASPX but am forced to use InfoPath form. According to what I've been reading, the .aspx one is the default, but I can't find where one switches it over to .xsn so I can reverse it).
    Monday, August 27, 2012 8:58 PM
  • I have the exact same problem (.aspx instead of .xsn, and .aspx forms don't close after clicking "Start", which is not interesting for the user, because he doesn't get a feedback of the action he just did).

    I'm searching for an answer on this. On a Vanilla Sharepoint Server, the form displays in .Xsn, and I don't know which setting was changed to force .aspx forms (that are not functioning well enough to be used).

    Thursday, September 27, 2012 2:48 PM
  • I have found this, which might be useful. However, since I can't edit the Workflow .aspx form for now (I don't have access to editing this page due to enterprise restrictions), I can't test what's written on there.


    Thursday, September 27, 2012 3:53 PM
  • Looks like the only thing that needs to be done is the “OffWFCommon” feature with an ID (c9c9515d-e4e2-4001-9050-74f980f93160) has to be disabled on your site collection. Each next workflow will generate ASPX forms instead InfoPath (XSN). You'll be able to edit them with SPD like any other ASPX form. Have fun guys!

    Filip Stankiewicz

    Tuesday, September 3, 2013 1:23 PM