locked
EdgeSync - LDAP Server is unavailable. RRS feed

  • Question

  • Trying to subscribe a 2016 Edge Transport server. I created the subscription but when I run or test Edgesync I get the error that the LDAP server us unavailable.

    The error in event viewer says:

    Failed to connect to the Edge Transport server ADAM instance with exception The LDAP server is unavailable..  This could be caused by a failure to resolve the Edge Transport server name <server name> in DNS, a failure trying to connect to port 50636 on <server name>, network connectivity issues, an invalid certificate, or an expired subscription.  Verify your network and server configuration.

    I have verified that the correct port 50636 is open on the firewall. I can ping by name in both directions. Subscription is not expired as I just created it.
    I do see an error in event viewer about the certificate...

    Microsoft Exchange couldn't match certificate when contacting <server name>. The connection was stopped.

    This article discusses the need to not have the same 3rd party cert on both the hubs and edge.
    https://blogs.technet.microsoft.com/karthikm/2016/09/24/error-edgesync-service-cannot-connect-to-this-subscription-because-of-error-the-ldap-server-is-unavailable/

    I do not have a third party cert on the Edges at all. And I regenerated the self-signed cert and re-did the subscription multiple times with the same result.

    Hoping someone has another suggestion before I call Microsoft support.



    Kenny

    Saturday, February 17, 2018 2:54 PM

Answers

  • Suggestions were all things I had already tried. Amazingly it just started working. Don't know why.

    Kenny

    • Marked as answer by Kas333 Wednesday, February 21, 2018 8:01 PM
    Wednesday, February 21, 2018 8:01 PM

All replies