locked
Word 2010 mail merge RRS feed

  • Question

  • When I try to use mail merge wizard and select an excel document as my data source, it brings up a box that says "select table" - but I can't select anything.
    Monday, November 19, 2012 3:32 PM

Answers

  • In the dialog box, do you see a button at the bottom left titled "Options..."

    1. If so,

     a. this is unusual. More about that below in point (3)

     b. you should also see a textbox titled "Workbook". If possible, make sure it is the one you want. I say "if possible" because if the folder/file name is long, you won't be able to see all of it

     c. click the Options... button, and select all 4 options, then OK. "table names" may appear.

    2. If it isn't that, do you see a list of tables, or no tables? Do you see a checkbox at the bottom left - the text is something like "First row of data contains column headers"?

    3. Word has a number of different mechanisms for getting data from an Excel sheet. By default, Word 2010 uses "OLE DB". If you see the dialog in point (2), you are seeing the OLE DB dialog box, but at this point I don't know why you can't select a sheet or table.

    If Word cannot use OLE DB, it may try using ODBC. (or someone may have set up your Mail Merge Main Document to use ODBC). But that usually indicates that something is wrong with the workbook. COuld it be a .xlsx that actually does not contain a workbook, for example?

    If Word cannot use ODBC, it may try to use the oldest method, DDE. People often use DDE anyway to connect to Excel data because of other problems, but it has a number of limitations, including

     a. it can only read data from the first sheet in the book

     b. it can only read "ANSI" or "OEM" characters. If you don't have unusual accented characters or other thing that you can only get in Unicode, that should not be a problem.

    It is often worth trying to use DDE if the other methods do not work - check Word->File->Options->Advanced, look for the General section (near the bottom), and check "Confirm FIle Format Conversion on open". Then go through the process of attaching the data source again. When you see "Confirm Data Source, select the DDE option. If you do not see it, check "Show All" and look for the Excel via DDE option.

    If that gets you nowhere, I suggest you create a very simple new data source in Excel and see if you can connect to that.


    Peter Jamieson

    • Marked as answer by Max Meng Wednesday, November 28, 2012 7:18 AM
    Monday, November 19, 2012 8:17 PM