locked
The "write-access" speed is more than 13 times larger than the "read-access" speed in an OCZ Solid-State Disk under Microsoft Windows Home Premium RRS feed

  • Question

  • I use a Western Digital WD5000AAKB-00H8A0 ATA drive as the main boot drive under Microsoft Windows Vista Home Premium on my computer.  The drive is connected to the first of the two IDE connectors on the motherboard and it is the only drive on that drive cable.  It is also set to be the master drive on that IDE channel.

    I have also been using an OCZ-SOLID2 Firmware Version 1.6, 120 GB, SATA  solid state disk drive for more than a year.   The SATA drive is connected to a VIA VT-6421 PCI RAID SATA adapter as an individual drive with no other drive on the card, and the operating system is running the most recent version of the VIA's device driver for this card:  V-RAID_v6.10a, VIA RAID Controller - 3249. 

    The computer has 1.5 GB of random-access memory with an 2.4 GHz Intel Pentium 4 microprocessor.  Typically, about 700 MB of the random-access memory is used as the "cache" by the operating system.

    I was very happy with the "write-access" speed of the OCZ drive.  For large files (much larger than the cache memory in the operating system), it routinely achieved a sustained transfer rate of about 49 MB per second, for a file move from the Western Digital drive to the OCZ Solid-State drive, as shown below ("H:" is the Western Digital Drive, and "F:" is the OCZ drive):

    Recently, while tracing a forced-seek problem on the Western Digital drive, I noticed that the "read-access" speed of the OCZ Solid-State drive is nowhere near its "write-access" speed.  This was utterly astonishing as  the "write process"  is usually more time consuming than the "read process" on almost any drive.  The "read-access" speed of the OCZ Solid-State drive is shown below, with the same large file structure (two .iso format, DVD image,  Linux distribution files) used in testing the "write-access" speed:

    As clearly seen, the ratio of the "write-access" speed to the "read-access" speed is (48.7 MB per second / 3.70 MB per second) = 13. 162162... 

    This is too large a speed difference for a solid-state disk drive, for a write-to-read ratio.  The other way around would have been more tolerable, as you could load the disk at your convenience slowly, but it would have served the data 13 times faster when you would have needed them. As it is, you can record very fast but, you could not get the data back in any reasonable time in the field.  It seems to have been manufactured for a field recorder which writes the data fast, instead of a computer where you want the data (like the ready made programs and large data blocks) to read back fast.

    I checked the OCZ web page, and they do have Firmware update (Version 1.7) which they do not recommend unless it is absolutely necessary, and its release notes mention nothing about the speed difference.  I'll discuss this with them and see what I can find out. 

    Needless to say, I also tested the "write-access" speed of the Western Digital drive using the same files from, this time, an USB-2 disk drive (another Western Digital fast drive with a SATA to USB-2 adapter).  This speed came out to be more than 5 times the "read-access" speed of the OCZ Solid-State drive despite the somewhat slower USB-2 interface.  So, it is definitely the OCZ Solid-State drive that is having the problem.

    As usual, I'll look into this further as I find time, and let you know what happened...

    -- Yekta


    • Edited by Yekta_Gursel Sunday, December 16, 2012 9:18 PM More data added.
    Sunday, December 16, 2012 8:53 PM

All replies

  • I tried to use the OCZ Forums in the OCZ Web pages.  During registration, they require an answer to a random question which asks: "Do you fly an APPLE or an AEROPLANE?".  I am a FAA Certified Flight Instructor and a Commercial Pilot, and I answered the question with "I fly an aeroplane."  It refused my forum registration, stating that the answer to the random question was incorrect.  This is the first registration process I have ever seen which requires you to lie to complete the registration. 

    Needless to say, I did not lie to register.

    I had to fill a trouble ticket with their technical support.  The ticket went in.  I am waiting for their answer.

    -- Yekta

    Monday, December 31, 2012 7:50 PM
  • The technical support person at the OCZ replied to the trouble ticket and he told me that the Forum registration procedure required a single-word reply, instead of a complete sentence.  I noted that the random question was a "so-called" security-type question, with an answer supposed to be known only by me and not something that could be guessed by the system.  However, their system did not work that way, and I told him not to worry about the Forum registration issue.

    He also wanted to see the results of a particular disk drive speed test performed on my OCZ Solid State Disk drive as connected to my system.  This test program is available from "attotech.com" and it is known as the "ATTO" test.  I got the program and performed the tests.

    The first picture shows the result of the direct I/O test with overlapped I/O.  The test has verified my measurements of the disk speed using large-file copy operations.

    The second picture shows the OCZ SSD drive parameters as connected to my system:

    The technical help person at OCZ looked at these results and he said that he did not know exactly why the read-access speed was much lower than the write-access speed.  However, they did have a destructive firmware update (version 1.7, from version 1.6) for the solid state disk drive electronics which might or might not fix this problem, and he asked me whether I wanted to perform this update, as it would destroy any data that were on the disk at the time.  I had backups of this particular drive, so I said that I would perform the update, and he sent me the link to the instructions for performing  the update.

    The destructive update process required first making a bootable DOS USB stick, using a small package originally from Hewlett-Packard.  I made a 2 GB bootable DOS USB stick with the destructive update program on it.  The machine with the OCZ SSD did not boot from the USB stick due to its BIOS, so I put the stick on another machine with a newer BIOS and tried to boot the machine from it.  The machine got stuck in the boot process with a linux boot loader displaying the single word "GRUB".  I figured out why this was quickly.  The software from Hewlett-Packard did not copy a few system ".sys" files, namely "config", "sys", and "wsys", to the USB stick after formatting it and making it bootable.  I manually copied these files from the Hewlett-Packard distribution to the USB stick and the machine booted to DOS from the USB stick without any further problems.

    There were two other requirements by the destructive update process: The OCZ Solid State Disk drive with its SATA interface had to be connected to an IDE multiplexed SATA interface, not to Intel AHCI based SATA, or RAID based SATA, or PCI based SATA (like VIA 6421A based PCI card as I had it).  The machine with the newer BIOS had IDE multiplexed SATA ports.  The update process also required a hardware jumper placed on the two particular pins on the OCZ SSD drive.

    I took the drive out of the machine with the older BIOS and put it on the IDE multiplexed SATA interface of the machine with the newer BIOS, after placing the jumper on the pins.  I booted from the USB stick and the initial part of the update procedure worked without any problems.  I shut the machine down and rebooted to Microsoft Windows Vista to complete the update.  That worked as well, and after removing the jumper, initializing and quick-formatting the drive I had the OCZ SSD with the new firmware (version 1.7) working on the machine with the newer BIOS.

    The newer BIOS was only needed for being able to boot from the USB stick for the update.  However, there was one more difference:  The IDE multiplexed SATA interface.  I decided to test the drive using the ATTO program, on the IDE multiplexed SATA interface.

    My next reply shows the results of this test, due to the "number of pictures per message" limitation in this forum...

    -- Yekta

    Saturday, January 19, 2013 3:52 AM
  • Here is the result of the ATTO test with the OCZ SSD on the IDE multiplexed SATA interface:

    And, the OCZ SSD drive parameters showing the firmware version:

    Now, the drive is performing very nicely.  My next reply shows the actual "large-file copy" speeds on this IDE multiplexed SATA interface...

    -- Yekta

    Saturday, January 19, 2013 4:08 AM
  • Here are the "large-file read and write" operation speeds on the IDE multiplexed SATA interface ("F:" drive is the OCZ SSD):

    As clearly seen, the read and write speeds are well matched on the IDE multiplexed SATA interface.  The slower results are due to the fact that the directory "Yekta" is on a magnetic disk drive.  "ATTO" test are performed without the involvement of a magnetic disk drive, or anything else.

    The next step was to install the drive back into the machine with the PCI VIA 6421A SATA interface and see how it performed.  Not surprisingly, it worked the same as it always did:  49 MB/sec write-access and about 3.7 MB/sec read-access.  The problem is definitely due to the interface difference.  Somehow, the OCZ Solid State Disk drive wants to see IDE multiplexed SATA interface.  Otherwise, it seems to perform what is called a "safe-read": Read slowly, but surely.  However, this is neither required nor desired.

    I'll look into this further and let you know...

    -- Yekta


    • Edited by Yekta_Gursel Saturday, January 19, 2013 4:39 AM Typographical error is fixed.
    Saturday, January 19, 2013 4:28 AM