none
Multivalued attribute replace instead of update RRS feed

  • Question

  • Hello

    I've developed a custom agent (ECMA 2.3?, MIM 4.3.2195.0), for some time it's worked as expected, but after adding some new features it's broken.

    MACapabilites.ExportType is set to AttributeUpdate, that's mean for multivalued attribute to take care of deletes old and adds new values and bring them to export phase.

    Case: Object Obj with multivalued attribute Attr changed value from M to N

    On export csentry have such settings:

    Correct behavior (Was)

    1. Obj.ObjectModificationType set to ObjectModificationType.Update
    2. Attr.ModificationType set to AttributeModificationType.Update
    3. M.ValueChanges.ModificationType set to ValueModificationType.Delete
    4. N.ValueChanges.ModificationType set to ValueModificationType.Add

    Incorrect behavior (Now)

    1. Obj ObjectModificationType set to ObjectModificationType.Update
    2. Attr.ModificationType set to AttributeModificationType.Replace
    3. N.ValueChanges.ModificationType set to ValueModificationType.Add

    Current behavior is same as in ECMA 2.0 or ExportType = AttributeReplace.

    I've checked ExportType in run-time and MIM DB table [dbo].[mms_management_agent], ExportType is 1 (AttributeUpdate).

    I don't want to recreate agent as it has accumulated data saved in CS, and it's painful to lost it. Need your help:)



    • Edited by Aloneone Sunday, June 12, 2016 3:57 PM
    Sunday, June 12, 2016 3:12 PM

Answers

  • Solved:)

    While refactoring agent schema, all AttributeOperation were deleted. I'm using virtual attributes, which store only in CS. Such attributes must be marked with AttributeOperation.ExportOnly, to exclude them from full import.

    • Marked as answer by Aloneone Monday, June 13, 2016 10:08 AM
    Monday, June 13, 2016 10:08 AM