none
DNS Server is not Creating/Updating PTR Records for Hosts

    Question

  • For all DHCP and Static host records don't create corresponding PTR records. All the reverse zones created perfectly. All the hosts checked with " Add Appropriate PTR Entry". 


    I have gone through this link and implemented but no change
    http://blogs.msmvps.com/acefekay/2009/08/20/dhcp-dynamic-dns-updates-scavenging-static-entries-amp-timestamps-and-the-dnsproxyupdate-group/ 

    Only Solution i found is un-check " Add Appropriate PTR Entry" and check again and apply, It works but What about new records? and manually i cannot do for 4000+ records.

    I have script to create Bulk PTRs but i need solution that will make PTRs for all newly created Host records. What are the settings need to be done at DNS level etc.

    Thanks

    Monday, February 13, 2017 8:26 PM

All replies

  • Hi Genius,

    Normally, if we create the corresponding Reverse Lookup Zone in DNS server, when we create static A records, the PTR records will be created automatically with "Create associated pointer record" checked.

    For dynamic records registered by DHCP, please ensure the following setting is not checked:

    On the DNS server, please check if "Refresh" or Restart the DNS console could make the PTR records show up after configuring.

    Best Regards,

    Anne

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by SachinWaghmare Tuesday, February 14, 2017 6:52 AM
    Tuesday, February 14, 2017 6:35 AM
    Moderator
  • All of above settings have been configured but still no luck.

    I have configured Scavenging/Aging on forward lookup zone only and after 1 month i have configured on Reverse zones as i didn't know that each zone require separate configurations. It may cause problem?

    i need to configure Scavenging/Aging on all zones same time, what should i do? 

    Tuesday, February 14, 2017 8:13 AM
  • Hi Genius,

    Normally, Scavenging/Aging won't take affect to static records.

    Then, please convert to the following configurations, check if everything could work after then:

    1. Disable Scavenging and Aging for all zones;

    2. Make the zone's dynamic update type to be "Secure only";

    3. Make DHCP server register DNS records on behalf of clients (with the setting for DHCP on my last reply);

    4. Add the DHCP server to "DnsUpdateProxy" group in ADUC;

    5. Ensure related reverse lookup zone is create in DNS server.

    (Since when DHCP server will remove A and PRT records when the lease is change on clients, so we do not need to enable DNS aging and scavenging)

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 15, 2017 6:54 AM
    Moderator
  • Hi,

    Just to check if the above reply could be of help? If yes, you may mark useful reply as answer, if not, welcome to feedback.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 1, 2017 2:10 AM
    Moderator