locked
Power Query does not show in the menu bar RRS feed

  • Question

  • I am having a weird issue with Power Query not showing up on the menu bar.

    I have installed Power Query version 2.21.3975.261.

    Excel 2013 (15.0.4727.1000) MSO (15.2.4727.1001) 32 bit 

    Power Query shows up in the COM Add ins, and it is checked, but it does not appear on the menu bar.

    I have tried uninstalling PQ, repairing Office, re-installing PQ.  Checking the registry setting for LoadBehaviour.  I don’t know what to check next.  Any help is appreciated!

    Thanks in advance!

    Wednesday, July 8, 2015 6:25 PM

Answers

All replies

  • This is likely a silly question, but have you gone to File | Options, Customize Ribbon and made sure that Power Query is checked there?
    Thursday, July 9, 2015 12:27 AM
  • Not a silly question.  When I go to Customize Ribbon, Power Query isn't listed anywhere in the available tabs to show.
    Thursday, July 9, 2015 2:53 PM
  • Sounds to me that Power Query add-in is completely failing to load. Unfortunately the guidance from Microsoft on this is essentially restart Excel/reboot. Any chance that you can switch to the 64-bit version of Office, I have noticed significantly improved stability with 64-bit verses 32-bit for all of the Power* features.

    Do you see any kinds of errors popping up in Windows Event Viewer when you launch Excel?

    Here is official MS guidance and another troubleshooting option:

    https://support.office.com/en-SG/article/troubleshooting-power-query-2546eaa8-9893-4574-9ef9-afacb9b0b495

    http://www.codeproject.com/Articles/552349/Excelplusaddinsplustroubleshootingplusguide

    Thursday, July 9, 2015 3:10 PM
  • Are there any more suggestions?  I have tried everything that I can find with no luck.  Due to the desktop standardization in the company, we have to stay with the 32 bit version of office.

    Things I have tried:

    uninstalling PQ, repairing Office, re-installing PQ.  Checking the registry setting for LoadBehaviour

    uninstalling PQ and .Net, reinstalling .Net an PQ,

    uninstalling PQ, repairing office, uninstalling excel, reinstalling excel and PQ.

    I have 2 machines in the organization that have the same behavior.  PQ installs "successfully", but in the Com add-in I get an error message Load Behavior: Not loaded. A runtime error occurred during the loading of the COM add-in.

    Friday, August 28, 2015 1:22 PM