locked
Probable bug in network share authentication RRS feed

  • Question

  • Hello,

    I'm having this problem since Vista, but not on Windows XP. I observed this bug in the Ultimate version of Vista and Windows 7.
    The problem is when accessing a network share or browsing network shares on a computer in my LAN (e.g. by typing \\IP or \\COMPUTER-NAME or by using the Network "folder" in Explorer), I get asked for the username and password, which I fill in. I check remember credentials.
    However, when the computer is restarted, the credentials are forgotten , and I get the prompt again. I did not observe this issue on Windows XP (professional).
    I explored a bit further and in Windows 7 Credential Manager, the credentials that I tick to remember get stored with Session persistence . If I enter the credentials manually in the Credential Manager, they get stored with persistence Enterprise and are perserved with restarts (correct behaviour). If I enter them manually I don't get the prompt anymore.
    I believe this behavior is incorrect, since remember credentials should remember the credentials forever or for a longer period of time and not just until restart. Also I observed people having similar problems on forums some time ago.

    Thank you
    Friday, August 7, 2009 1:07 PM

All replies

  • Hi mrbrdo

    The other alternative to over come this issue is to map it's IP instead of the comps name
    Friday, August 7, 2009 2:16 PM
    Answerer
  • I am not sure if you are talking about the same thing, I am not talking about mapping a network share to a drive (like Z:) - even though this issue may exist there as well.
    I am talking about going to Computer - Network - click on a computer with network shares. After that I am asked for the password every time after reboot, even after checking remember credentials.
    There are workarounds but I think the implementation is bugged - it's not doing what it's supposed to do (it works like it's supposed to in XP).
    Also again i'd like to stress I am NOT refering to Home versions of the OS, but Ultimate (Professional in XP case).
    Friday, August 7, 2009 2:51 PM
  • Also, using IP instead of computer name does not help... (e.g. \\192.168.1.10). After reboot the password is forgotten (it gets stored with Session persistence).

    I really hope you guys fix this. This bug has been around since the release of Vista!
    Monday, August 10, 2009 5:41 PM
  • Please resolve this. Still present in Windows 7 Ultimate RTM (tested on English version).
    Monday, November 2, 2009 2:56 PM
  • My desktop has started doing this, after it and the laptop both worked fine under Beta and RC1.  The laptop is still fine.

    The problem started when I deleted an old computer from the list in Credential Manager.   That deletion seems to have clobbered its ability to remember anything after shutdown.

    Also, the Persistence is shown as "Logon Session" whereas on the laptop it's "Enterprise".   I don't know if that matters, and anyway I can't see a way to change it.

    Another bug in Win 7, methinks.
    Friday, November 6, 2009 4:52 PM
  • I've found a clunky work-around that seems to have fixed it.

    I entered manually the details for my laptop on the network, and checked that they were working.
    Then I added some "spoof" entries - 192.168.0.1 under "Windows Credentials" and the Laptop's credentials again under "Generic Credentials".
    Then I ran the "Back up Vauilt" thing and restored the same vault.   I got a shower of error messages from the system, which I ignored.

    Three times since, on shutdown and restart, all those entries returned.   I think it's sorted, albeit messy.   The Laptop shows with the little red X on startup, but clicking on it opens the drive with no problem.
    Saturday, November 7, 2009 2:09 PM
  • so is there any fix for this issue?
    Tuesday, February 2, 2010 11:23 AM
  • Well, I've not had any recurrence of the problem since I posted that work-around in November.  It may not be the most elegant solution, but it's worked for me.
    Tuesday, February 2, 2010 12:39 PM
  • This did not work for me. My Windows 7 forgets all the credentials for mapped drives and I have to reenter them after every restart. Problem is, this is happening almost universally domain wide. I can't find any solution.
    Wednesday, March 17, 2010 3:41 PM
  • I have the same problem, but it occurrs in the same session.  I don't need to reboot for windows to forget my credentials.  I will be working for an hour or two then bam, I can't get to any of my mapped drives on the server.  I get the error message:

    "The local device name is already in use. this connection has not been restored." 

    It does not ask me for my credentials, it just wont let me in.

    If I go to My Network and click on the server, it will ask for my credentials and then I can get acces to my mapped drives again.  Sometimes this happens two or three times a day and sometimes I can go for 3 or 4 days without any problems.  It can be a real problem if you have several programs running that are accessing files on the server through the mapped drives.

    I typically don't have any problems rebooting.  When the machine comes back up it remembers my mapping and credentials.  It is during the day while I am working that I have the problem.

    I am using Windows 7 Pro 64bit and I have mapped drives on our Windows Server 2008 64bit.  I log in with my domain name which has administrator privledges on the domain.

    Thursday, April 1, 2010 7:35 PM
  • Hello Ms Microsoft, I notice you've gone all quiet on this one.  I  have exactly the same problem when switching between users on Windows 7 client, lose my Windows Server 2008 network shares.  There is an authentication bug in your code...  If I persist I get the message that security has been compromised and a request to please supply a user name and login to reconnect.  It's like its forgotten that I'm logged on.  Please fix!
    Thursday, November 18, 2010 11:27 AM