locked
user mailbox not updated in gal RRS feed

  • Question

  • Our Environment: this particular new user mailbox not updated on GAL of Exchange 2010 environment.

    When creating this new user, there was a typo and it was corrected later, but the email address has been created with wrong email address and correct email address.

    I changed the primary email address to reflect his correct name and uncheck "automatically update email address based on policy", after that re-generate the OAB on server side, still no luck.

    when I use outlook without cache mode, I can see his detail on GAL.

    When I use outlook with cache mode, I can't see him on the GAL.

    I manually choose "Send and Receive" offline address book from outlook and still can't see him on the GAL.

    What else should I do?

    Tuesday, July 31, 2012 5:00 AM

Answers

All replies

  • Hi,
    Make sure that WindowsEmailAddress is the same as the PrimarySmtpAddress. If they are not the same, it would explain why the users is not showing up in the OAB.

    Check with: Get-mailbox USER | fl WindowsEmailAddress,PrimarySmtpAddress

    After you updated the OAB...Did you also update the OAB WebDistribution files?
    One easy way to do that is to restart the service msexchangefds.


    Martina Miskovic

    Tuesday, July 31, 2012 5:11 AM
  • Since you can see the new user in GAL when running Outlook in Online mode, it is OAB (Offline Address Book) issue, not related to email address policy.

    I would suggest you start with OAB generation process. See

    http://blogs.msdn.com/dgoldman/archive/2005/07/16/How-to-troubleshoot-the-OAB-Generation-process.aspx

    (refer to Exchange 2007 part)


    Hope itis hlepful.

    Fiona Liao

    TechNet Community Support

    Wednesday, August 1, 2012 8:57 AM
    Moderator