locked
Want to permanently disable Aero but it is occasionally getting invoked RRS feed

  • Question

  • We have laptops running a legacy application that does not display properly with Aero enabled.  We've tried to manually disable Aero in Control Panel\Personalization and set the theme to Windows Classic but occasionally (1 out of every 10 or so logins), the Aero theme will reappear.  We've also made a group policy entry under User Configuration\Administrative Templates\Control Panel\Personalization\"Force a sepcific visual style or force Windows Classic" for the system to always use Windows Classic, but it has not solved the issue.  When we log in and look to see what theme is being used under personalization, it will say "Unsaved Theme".

    These systems are standalone and not part of any domain, so it's not a policy that's getting pushed from a DC that's overwriting the local setting.  Any help would be very much appreciated!

    Monday, June 25, 2012 2:30 PM

Answers

  • Hi ,

    The easiest way to disable Aero in Windows 7:

    Right click the Desktop, click Personalize, under Basic and High Contrast Themes, click Windows 7 Basic.

    If you enable “Force a specific Visual Style file or force Windows Classic”, the Aero should be disabled.

    I enabled the policy on my test machine and restarted the machine, it use the Windows Classic theme. Although, it says "Unsaved Theme", the system still use the Windows Classic theme.

    User Configuration -> Administrative Templates -> Control Panel -> Personalization ->  Load a Specific Theme

    Specify the following path and filename: %windir%\resources\Ease of Access Themes\classic.theme


    Tracy Cai

    TechNet Community Support

    • Marked as answer by Cloud_TS Thursday, August 23, 2012 2:03 AM
    Wednesday, June 27, 2012 7:42 AM

All replies

  • Hi ,

    The easiest way to disable Aero in Windows 7:

    Right click the Desktop, click Personalize, under Basic and High Contrast Themes, click Windows 7 Basic.

    If you enable “Force a specific Visual Style file or force Windows Classic”, the Aero should be disabled.

    I enabled the policy on my test machine and restarted the machine, it use the Windows Classic theme. Although, it says "Unsaved Theme", the system still use the Windows Classic theme.

    User Configuration -> Administrative Templates -> Control Panel -> Personalization ->  Load a Specific Theme

    Specify the following path and filename: %windir%\resources\Ease of Access Themes\classic.theme


    Tracy Cai

    TechNet Community Support

    • Marked as answer by Cloud_TS Thursday, August 23, 2012 2:03 AM
    Wednesday, June 27, 2012 7:42 AM
  • I've also read you can disable aero by doing the below

    Click on Start, and in the Start Search field type regedit.exe and then press Enter.

  • If User Account Control prompts you for consent, click on continue or provide the appropriate credentials.
  • Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM.
  • Look for a REG_DWORD value named "Composition". If this key does not exist, create it.
  • Double click on the Composition (REG_DWORD) value and change its value to 0.
  • Log off and back on for this change to take effect.

Wednesday, June 27, 2012 8:02 AM
  • Real easy.  Go to services and disable the Themes service (stop the service first).  Once that is done, nothing will be able to activate Aero.

    Wednesday, June 27, 2012 3:58 PM