locked
SharePoint Designer 2010 and You do not have permission issue RRS feed

  • Question

  • Hi,

    We have a SharePoint 2010 farm configured in windows 2008 server and i have farm admin and site collection admin privileges. I have checked all the check boxes to open the site in SharePoint designer.

    But when i open the site in the SharePoint designer using my account or the service account (This also has same permission like me) i am getting the following error.

    "You do not have permission to do this operation. Ask your website administrator to change your permissions and then try again, or log on with a
    user account that has this permission. To log on with a different user account, click OK".

    I tried several threads in the internet and none of them helped me. What would be issue?

    How can i resolve this error?


    Kathir

    Thursday, April 26, 2012 9:58 AM

Answers

  • Hi All,

    We have figured it out after a long struggle.

    Here is the conflict.

    In my central administration-->Security-->Specify Authentication Providers-- Default (Click On Default)

    You will get a new page. In that look into the

    IIS Authentication Settings  -- Here the Basic Authentication check box is checked.

    Now open your IIS and go to your Site. Open the Authentication section.

    Make sure the Basic Authentication is enabled. In my case the "Basic Authentication is Disabled". This makes the error and headache for almost a day.

    So the solution is make sure when you enable the Basic Authentication in the central admin the same should be applied within the IIS settings.

    This solved the issue.

    Kathir

    • Marked as answer by Entan Ming Friday, May 4, 2012 2:57 AM
    Thursday, April 26, 2012 12:31 PM

All replies

  • Hi Kathir,

    Are SPD settings enabled at the site collection level as well? Also, can you let me know from where SPD is being opened? On the server?

    Regards,


    HTH, Krishnan

    Thursday, April 26, 2012 10:17 AM
  • Hi Krishnan,

    Yes. Its enabled. I tried in server as well as my local machine. Same issue in both the cases.


    Kathir

    Thursday, April 26, 2012 10:26 AM
  • Did you try launching SPD from the website once you have logged in?

    The only problem I see as of now is a credentials issue.

    Regards

    HTH, Krishnan

    Thursday, April 26, 2012 11:57 AM
  • I verified by opening it from the web site too. The same error.

    All the permission are correct and we have verified it several times. I don't see any permission higher than Farm Admin and Site Collection Admin.


    Kathir


    • Edited by karurkathir Thursday, April 26, 2012 12:04 PM More info
    Thursday, April 26, 2012 12:02 PM
  • Hi All,

    We have figured it out after a long struggle.

    Here is the conflict.

    In my central administration-->Security-->Specify Authentication Providers-- Default (Click On Default)

    You will get a new page. In that look into the

    IIS Authentication Settings  -- Here the Basic Authentication check box is checked.

    Now open your IIS and go to your Site. Open the Authentication section.

    Make sure the Basic Authentication is enabled. In my case the "Basic Authentication is Disabled". This makes the error and headache for almost a day.

    So the solution is make sure when you enable the Basic Authentication in the central admin the same should be applied within the IIS settings.

    This solved the issue.

    Kathir

    • Marked as answer by Entan Ming Friday, May 4, 2012 2:57 AM
    Thursday, April 26, 2012 12:31 PM
  • Hi Kathir,

        I am also getting same error struck for more than a day.Please help me do i need to follow above steps?

    Regards,

    Mohamed.

    Tuesday, February 19, 2019 6:01 AM