locked
Server 2008 R2 fails updates KB976932, KB979538, Internet Explorer 9 and 6 other packages. RRS feed

  • Question

  • Server was able to run all prior updates without any issues, but it got stuck on the last 9 updates. I tried them one by one, local download, System Update Readiness Tool, Subinacl, Windows Update Troubleshooter, etc, etc. 
    Nothing seems to fix this issue. I appreciate anyone's help. Thanks.

     

    Juan C. Dulanto

    Friday, November 27, 2015 4:50 PM

All replies

  • i would uncheck SP1 as a start and try to get the other updates installed then install the service pack manually

    if that poses issues you will have to run an SFC scan probably

    to narrow down what your issue is you need to review the CBS.log

    if the updates fail to install locally then this isn't a WSUS/Windows Update issue but you can review the windowsupdate.log anyway

    make sure your C drive has at least 15% free disk space, this is the most common reason why updates fail to install

    • Edited by armin19 Tuesday, December 1, 2015 2:05 PM
    • Proposed as answer by Steven_Lee0510 Tuesday, December 8, 2015 2:06 AM
    Tuesday, December 1, 2015 2:04 PM
  • I am still trying to get it fix. I unchecked SP1 and run the updates without success.

    Interesting note: IE9 was the first update to try to install and failed (according to update history).

    What if IE9 was previously installed and got corrupted or half way installed? I check all the Microsoft Updates, and IE9 did not appeared anywhere. Just in case I run the following  into the command prompt:

    FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*9.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"

    The command found several instances of IE9 and deleted them.

    I then downloaded a local copy of IE9 and installed using command prompt - followed by the switch "/update-no"

    Sucess!! I finally got IE9 properly installed and it works perfectly!

    I immediately try to install other missing updates without success.

    If you have any suggestions please let me know.


    Juan C. Dulanto

    Tuesday, December 8, 2015 2:04 PM
  • if System Update Readiness Tool is not fixing anything then i would do sfc.exe /scannow

    once that's done see if you can deploy the oustanding updates but again, reading the logs would be more informative as to what the issue is with those updates instead of guessing

    Tuesday, December 8, 2015 2:07 PM