none
Power Query SCCM Installation RRS feed

  • Question

  • I have been trying to create a SCCM application which will install Power Query after installing MSOffice Pro Plus 2013. On a machine which has the Office, I can manually install Power Query, however, silent and administrative installs do not work.  Has anyone successfully install Power Query through System Center as a system application (no user interaction)?  If so, what am I missing.

    Steps taking so far:

    Downloaded latest Power Query Software: "PowerQuery_2.13.3688.242 (32-bit) [en-US].msi"

    Created a new application from the MSI.

    Created a deployment.

    Tested deployment on Windows 8.1 Machine. Failed to install.

    Tested deployment on Windows 7 Machine. Failed to install.

    Tried on both Windows 7 and 8.1 Machines to install by command line (admin command prompt) with /a or /I with /qn and will not install.

    In event viewer return code is installation success or error status: 0.

    Verified com add-in is not present.

    Tried on Windows 7 and 8.1 machines installing with no flags and installs successfully.


    Wednesday, July 16, 2014 4:09 PM

Answers

All replies

  • Hi Christopher,

    Could you try running the Power Query installer with this option to generate a log?

    > PowerQuery.msi /l*vx log.txt

    The generated log.txt file should have useful information for us to debug. Feel free to post it here or send it to us via email at pqfb [a.t] Microsoft.com

    Thanks,
    M.

    Friday, July 18, 2014 4:27 PM
  • Found it, I needed to set ACCEPT_EULA=1
    Friday, July 18, 2014 7:19 PM
  • Hi, 

    I've tried to install PQ through SCCM it failed. I'm using command: msiexec /i "PowerQuery_2.16.3785.242 (64-bit) [en-us].msi" /q ACCEPT_EULA=1

    This command works when I run cmd as Administrator on local machine (non-domain joined). But when cmd runs as a regular user (this user is local admin) it fails. SCCM tries to run it as local admin.

    SCCM gives following error: 0x643 (1603).

    Google says that it is related with elevation. Note: Run as Administrator feature blocked on client machines through GPO.

    Could someone help me?

    Monday, October 20, 2014 4:33 PM
  • Put this command in bat file and right click and use run as administrator..
    • Proposed as answer by VishalPawarMVP Tuesday, November 18, 2014 4:22 AM
    Tuesday, November 18, 2014 4:22 AM