none
Need to restrict anyone from adding to the Enterprise Resource Pool but the Admin RRS feed

  • Question

  • We've decided to just allow the admins to build and edit the Enterprise Resource Pool.  how can I restrict the access from others.  I think I am disallowing the correct permissions (glabal and category) but something is wrong:

    I have a user group where the global permission of "new resource" is not checked and the categoriy permission of "edit resource data" is no checked.  However, in testing this I found that:

    1.  When a Project Manager is logged; from PWA>Resource Center...the PM cannot add to the pool (icon is gray), nor edit the resource (icon is colored but error occurs if they try) BUT, they can "open" the pool which takes them to a checked out resource sheet where it can be modified and imported right in to the pool.

    2.  Next scenerio, Open PWA>Project Center>open project>edit using project professional>resource tab>"add resource" icon is in color and allows the import wizard option.  Testing this wizard also added them to the pool.

    What permissions am I missing???  We are using MS Project Server 2010

    Tuesday, December 11, 2012 8:19 PM

Answers

  • Hi Paul,

    I think I descovered what I was doing wrong.  From my pc (the admin), I logged in as another person (PM role). When I went to PWA and opened the project through Project Professional, it was opening up with me (my admin permissions).  I retested from the other users pc and everything looked fine.  Thanks for responding.  :)

    • Marked as answer by K-Dee Thursday, December 13, 2012 6:39 PM
    Thursday, December 13, 2012 6:39 PM

All replies

  • Hi there,

    Do the other groups/users have the following global permission enabled:

    • New Resource

    And the following Category permssion:

    • Edit Enterprise Resource Data

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, December 11, 2012 10:02 PM
    Moderator
  • Hi Paul,

    I think I descovered what I was doing wrong.  From my pc (the admin), I logged in as another person (PM role). When I went to PWA and opened the project through Project Professional, it was opening up with me (my admin permissions).  I retested from the other users pc and everything looked fine.  Thanks for responding.  :)

    • Marked as answer by K-Dee Thursday, December 13, 2012 6:39 PM
    Thursday, December 13, 2012 6:39 PM