none
Sharepoint 2007 integration with Access 2007 - Schema's not changed, why does Access think it is? RRS feed

  • Question

  • Greetings,

    I have a custom business application (a library catalog) built upon SharePoint 2007 that keeps its data in a series of SharePoint Lists.

    I have been using Access 2007 (and more recently, Access 2010) as a frontend to update data in the lists because it's more efficient than making changes through the web UI.  This works great, except for one frustrating error.  Every time I open a database that connects to the SharePoint Lists and attempt to edit them, Access tells me, "The schema for this table has changed.  You must refresh the table before editing or adding new records." The problem is that Access is lying -- the schema hasn't changed.  Refreshing the list fixes the problem, but given the fact that nobody is changing the schema on the SharePoint site, it would be a lot better if I could update my lists without always having to refresh the lists every time I launch the database.

    Given that the schema is not changing, what is actually going on here, and what can I do to get Access to stop throwing this error at me every time I want to update my SharePoint Lists?  Alternatively, how would I go about making the lists refresh automatically every time I open the database?

    Thanks,

    Marijane White

    • Moved by Mike Walsh FIN Tuesday, July 19, 2011 6:08 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Monday, July 18, 2011 8:02 PM

All replies

  • Hi Marijane,

    I tried to reproduced your issue but it worked as expected.

    Did only your Access 2007 appear this issue?

    I would suggest you to repair the Office, then delete the linked table and re-link the list in Access, and check the result.
    And you can check the 12\LOGS file whether there were some useful error information.


    Thanks,
    Daniel


    Regards, Daniel
    Friday, July 22, 2011 9:01 AM
    Moderator
  • Hi Daniel,

    No, it happens with Access 2010, too.    I have recreated the links to the tables many times, as well as trying to recreate the links from scratch in new Access database files, but it still happens.

    Thanks for the pointer to the logs, I will check them out.
    Friday, July 22, 2011 5:11 PM
  • Hi Marijane

    Did you find an answer to your problem?  If so would you care to share it ;-)

    I too had this issue. 

    Mine was slightly diffrent in that when trying to ADD NEW data the error popped up because of a duplicate value where a unique constraint existed.  Not sure if this will affect your scenario.

     

    A shame that it can't report that there is a unique constraint preventing the addition - this error is somewhat ambiguous.

     

    Also note that I am running SharePoint 2010 (Foundation) so there may be slightly different issues for you.

    Stu

     

     

     


    • Edited by Stu Hebron Monday, November 7, 2011 5:57 AM
    Monday, November 7, 2011 5:27 AM
  • I'm just getting the same issue.

    I am trying to run an Access update query to bulk-change a lookup value in a linked-to-access sharepoint list. i.e. Replace '3' with '1'...

     The truth is out there?

    Thursday, June 21, 2012 1:52 PM
  • Quick update: I think I have figured it out for my condition: I need to go to the SharePoint EXTERNAL DATA / SHAREPOINT LIST dialogue box and (re-)import the table to my database. That seems to do the trick.... Regards, Brian.
    • Proposed as answer by RunnerIE Thursday, June 21, 2012 2:24 PM
    Thursday, June 21, 2012 2:22 PM
  • Hi Marijane and Stu, 

    Was the issue "The schema for this table has changed. You must refresh the table before editing or adding new records" ever addressed? I would like very much to see the solution that works. I am having the same error.  Than ks, Davester,

    Monday, April 15, 2019 9:06 PM