none
DistributedCOM error 10000: Unable to start a DCOM server RRS feed

  • Question

  • Unable to start a DCOM Server: {06622D85-6856-4460-8DE1-A81921B41C4B}. The error:"2"Happened while starting this command:C:\Windows\SysWOW64\DllHost.exe /Processid:{06622D85-6856-4460-8DE1-A81921B41C4B}

    Been getting this error for years and can't access certain control panels directly (but can through full control panel) like desktop "personalization" (clicking any links under "See also" in this window does nothing). Control Panel refuses to show its cascading menu in the Start Menu too.

    06622D85-6856-4460-8DE1-A81921B41C4B is COpenControlPanel. I searched for these in the registry editor but couldn't find the command-line used in the error which, if I run in a command prompt, gives this error:

    This version of C:\Windows\SysWOW64\dllhost.exe is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

    If I run c:\windows\system32\dllhost.exe /processid:{06622D85-6856-4460-8DE1-A81921B41C4B} it works fine. How do I get DCOM to use the 32-bit dllhost.exe? I've tried the backup 64-bit dllhost.exe in C:\Windows\winsxs\x86_microsoft-windows-com-surrogate_31bf3856ad364e35_6.1.7600.16385_none_43fa44d954d596e7 but get the same bit-depth conflict error above.

    Any ideas? Thanks.

    • Edited by Eep2 Friday, November 2, 2018 3:08 AM
    Friday, November 2, 2018 3:04 AM

All replies

  • Hi,

    Based on your description, I found an article may help you, please refer to the link:

    http://kb.eventtracker.com/evtpass/evtPages/EventId_10000_Microsoft-Windows-DistributedCOM_62595.asp

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 5, 2018 5:38 AM
    Moderator
  • That's a pretty generic article but I went through it anyway to no avail. My virtual memory page file is at the recommended size for my 16GB of RAM. The COM permissions look fine too, though that article doesn't explain how to set them but I looked for my name and all the permissions are there, as well as for admins and the system.

    • Edited by Eep2 Saturday, November 10, 2018 1:09 PM
    Saturday, November 10, 2018 1:02 PM