locked
Vista disabled sleep mode / sleep mode grayed out. RRS feed

  • Question

  •  On My Dell laptop, the sleep option on the start menu is greyed out and the computer will not sleep when I close the lid. But when I reset the power plan to default settings, the sleep option on the start menu is no longer greyed out and the computer will go into and out of sleep mode with no problems. However when I restart it the sleep mode becomes disabled again. I have tried powercfg/a command to see what was wrong, and all it tells me is that under (S3) "The current power policy has disabled this standby state. I have tried updated video drivers, but it didn't work. I dont know what to do at this point, and help would be appreciated. Thanks
    Monday, May 18, 2009 5:22 AM

Answers

  • I think I found the solution to this problem.

    This solution has kept the standby option available through several restarts and has not been grayed out once since.

    What I did is as follows.

    Open gpedit.msc using command prompt or the "Run" tool.

     The path was: Computer Confuguration > Administrative Templates > System > Power Management >
    Sleep Settings > (see below for catagories)

    Button Settings >

    Start Menu power Button action Enabled to sleep (both battery and plugged in)

    Lid Switch Action set to sleep (both battery and plugged in)

    Sleep Settings >

    Allow standby states (S1-S3) (both battery and plugged in)

    (The latter seems to be the most important action.)

    Thanks for the idea Dale and for responding so quickly.

    Sunday, May 31, 2009 5:27 PM

All replies

  • Hi,

     

    Thank you for posting in Microsoft TechNet Forum.

     

    Generally, the computer can't be put to sleep mode if either of situation mentioned in the following website is true:

     

    Why isn't Sleep available

    http://windowshelp.microsoft.com/Windows/en-US/Help/b647af87-9988-4d4d-9709-8097f88c916f1033.mspx

     

    You can take the suggestions in the web first.

     

    To move on, I noticed that you have restored the default power settings and it worked normally before a restart. Thus I suspect that you can’t change these system settings, it might be related to Group Policy settings in your computer. Here I recommend that you use Group Policy Log View tool to export Group Policy event data from the system and operational log into a text, then post it in this thread.

    Group Policy Log View
    http://www.microsoft.com/downloads/details.aspx?FamilyId=BCFB1955-CA1D-4F00-9CFF-6F541BAD4563&displaylang=en

     

     

    Meanwhile, I would like to share a Microsoft KB on standby issue.

     

    How to troubleshoot performance issues with standby, hibernate, and resume in Windows Vista

    http://support.microsoft.com/kb/950686

     

    Hope this helps. Thanks.
    Tuesday, May 19, 2009 8:14 AM
    Moderator
  • Thanks for your reply, I tried all the options except the group policy program (I couldn't figure out how to work it). The Performance Information and Tools program said the Intel video driver was interfering with windows resuming from sleep mode. The Event Log Said that The driver was causing the computer to resume more slowly that usual. The Event Log report is below. I think this issue is driver related, so I might have to wait until Dell comes out with a new driver.

    Level Date and Time Source Event ID Task Category
    Error 5/19/2009 9:20:44 AM Microsoft-Windows-Diagnostics-Performance 351 Standby Performance Monitoring "This driver responded slower than expected to the resume request while servicing this device:
         Driver File Name  : \Driver\igfx
         Driver Friendly Name  : Intel Graphics Kernel Mode Driver
         Driver Version   : 7.14.10.1409
         Driver Total Time  : 2076ms
         Driver Degradation Time : 1078ms
         Incident Time (UTC)  : 5/19/2009 5:22:20 PM
         Device Name   : PCI\VEN_8086&DEV_2A02&SUBSYS_01F91028&REV_0C\3&2b8e0b4b&0&10
         Device Friendly Name  : Mobile Intel(R) 965 Express Chipset Family
         Device Total Time  : 2086ms
         Device Degradation Time : 0ms"

    Thanks again for your advice.

    Wednesday, May 20, 2009 12:55 AM
  •  

    Hi,

    Thank you for responding prompted.

    From the Event Log, we can see that this issue is related to device driver. Based on my research, to troubleshot this kind of issue, you need to update your video driver and BIOS for your motherboard. You may contact Dell to obtain this.

    Meanwhile, to make sure you have the latest Video drivers and BIOS for your motherboard, please read your motherboard manual to see if you have any jumpers or settings that sets different sleep voltages for USB.

    For detail steps, please visit the following website.

    http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Hope this helps. Thanks.

     

     

    Wednesday, May 20, 2009 9:49 AM
    Moderator
  • Thanks for your help, This problem seems to have been resolved by updating the BIOS the chipset and the Video drivers. I also had to disable the OHCI IEEE 1394 Host controller because the event log said it had been interfering with the computer resuming from standby. Again, thanks for your advice and responding so promptly.

    Friday, May 22, 2009 11:32 PM
  • Hi,

    I am sorry for a delayed response.

    What operation leads to this caution? When was the sleep button grayed out again? Have you perform System Restore before?

    A screenshot about this caution is preferred.

    Screenshot

    ==========

     

    1. Press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click “Desktop” on the left pane and then click "Save".

    6. Upload this picture to SkyDrive ( www.skydrive.live.com ), then edit what you reply with HTML.

    7. Insert the following code.

     

    <IMG height=600 alt=08 src="URL of the picture" width=800>

     

    Note: URL of the picture = the URL to the picture that you want to post.

     

    Hope this helps. Thanks.

     

    Wednesday, May 27, 2009 10:08 AM
    Moderator
  • There wasn't any "Caution" warning per se. thet was just me talking to somone with the same problem reading the post so they could repeat what I did to fix it. Sorry about the misunderstanding.  As far as when the problem happened again, after Updating the BIOS, Chipset And Video drivers The sleep function was working properly after several reboots. After I re-rated the system performance (It said "new hardware has been detected") the sleep option was once again grayed out, so i had to re-install the video driver to make the system think it had a new video card. However that didn't work, so now I have to restore default power plan settings every time I re-boot the system. I also have a new problem where after hibernate the screen stays blank and it will not let me into the log-on screen. I "fixed" the latter problem by setting the lid close option to do nothing in the power plan, so now I just have to press the power button. I'm beginning to think this problem is not an easy fix, before I updated the computer to Vista while I was using XP everything was working very well. I hope this is just because vista is still in it's early stages or somthing like that.
    Wednesday, May 27, 2009 9:16 PM
  • I think I may have found a possible solution. In an earlier post you mentioned somthing about group policy disabling standby, so I decided to do a google search about how to enable sleep by group policy. What I found was directions on how to disable sleep using group policy. However I used that information and was able to (at least for now) enable sleep mode with no problems so far. If this continues to work I might post what exactly I did to help others that might be having the same problem.

    Friday, May 29, 2009 9:52 PM
  • I think I found the solution to this problem.

    This solution has kept the standby option available through several restarts and has not been grayed out once since.

    What I did is as follows.

    Open gpedit.msc using command prompt or the "Run" tool.

     The path was: Computer Confuguration > Administrative Templates > System > Power Management >
    Sleep Settings > (see below for catagories)

    Button Settings >

    Start Menu power Button action Enabled to sleep (both battery and plugged in)

    Lid Switch Action set to sleep (both battery and plugged in)

    Sleep Settings >

    Allow standby states (S1-S3) (both battery and plugged in)

    (The latter seems to be the most important action.)

    Thanks for the idea Dale and for responding so quickly.

    Sunday, May 31, 2009 5:27 PM