locked
SearchIndexer.exe causes explorer to hang RRS feed

  • Question


  • Hello.  I am having a problem with a new Dell E6410 laptop whereby windows explorer hangs for around 3-8 minutes on almost any file related operation eg:open window, or start an application that wants to open a document.  It doesn't crash, just hangs, and operation continues after the 'timeout' for another minute or two or just a few mouse clicks before the next hang.  It is not making file errors during or after these hangs. It always recovers eventually, but the machine is essentially unusable in this state.

    Some aspects of the machine continue to work eg:the Date and Time Properties window continues to track time but the clock in the taskbar is frozen.  Task Manager shows the CPU to be mostly idle (98%) and Sysinternals Process Monitor shows the hard disk also just ticks over with the occasional read/write, including SearchIndexer.  Event viewer doesn't show any obvious cause.

    The laptop came with the company domain load of XP SP3 and Office and a few apps, so it's clean.  The problem was caused by installing Windows Search 4, although 3 also causes it.  It happens on or off the network.  Stopping SearchIndexer.exe does not fix the problem but disabling it alone and rebooting completely eliminates the hangs.  Setting default and rebuilding indexes does not cure the hangs.  Subjectively it hangs more with an incomplete index.

    Having used WDS for a few years I now have a filing system that relies upon it.  As the computer doesn't seem to make mistakes and doesn't seem to be 'doing' anything, I am now at a bit of a loss where to look.  Any suggestions?

    Thanks.
    Thursday, December 30, 2010 12:57 PM

All replies

  • Try this from JBozward

    Before doing this. Consider leaving this running after you leave for the evening!

    Start the computer management control panel.

    Expand "services and applications"

    Stop the Indexing services by right clicking and then "stop"

    Right click Indexing Service >all tasks> then tune performance.

    Select the customize radio buton then customize button.

    Select Instant

    Ok. then Ok

    Try playing with the other settings for a balance of performance.

    If helpful thank JB 

     

    Keith

     

     

    Saturday, January 8, 2011 11:24 AM