none
GPO - Printer deployment installing incorrect driver for clients

    Question

  • Hi All,

    I'm running Server 2012 R2 using print management (print server) with GPO for printer deployment (per machine connection type). On the server it's installing the correct printer (HP) driver, but on client machines (Windows 7) it's installing an incorrect driver (MS enhanced point & print compatibility driver). In GPO I've messed around with the "Package Point and Print - Approved server", "Only use Package Point and Print", and "Point and Print Restrictions", but it doesn't make a difference. Any thoughts on how to get the correct driver installed on client machines?

    Thanks

    Monday, February 27, 2017 3:52 PM

All replies

  • Hi,
    Please offer us the detail settings about how and where you configured "Package Point and Print - Approved server", "Only use Package Point and Print", and "Point and Print Restrictions".
    In my experience of the similar problem, pleas have a try to disable "Point and Print Restrictions" under computer\admin templates\printers\ and see if it helps.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, March 02, 2017 7:02 AM
    Moderator
  • Hi,

    Was your issue resolved? If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions. If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 06, 2017 8:35 AM
    Moderator