locked
Shortcut shows extension of the linked program RRS feed

  • Question

  • Since some days, a newly created shortcut on the desktop shows the extension of the linked program too. For example, if I link Explorer.exe it shows Explorer.exe  If I switch the chortcut extension on too, it looks like: Explorer.exe.lnk

    I already replaced the .lnk and lnkfile entries in the registry under HKEY_CLASSES_ROOT, but the extension won't disappier.

    Any clues? Thank you.

    Sunday, March 27, 2011 10:27 AM

Answers

  • I just checked my systems (one running Windows 7 SP1 and another without SP1) and observations are the same. Looks like it's absolutely normal.

    Perhaps you had the setting "Hide extensions for known file types" enabled previously, and lately you had unchecked it? That might be causing the difference.

     


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Cloud_TS Thursday, March 31, 2011 9:04 AM
    Monday, March 28, 2011 2:34 PM
    Answerer

All replies

  • have you tried this?

     

    File Association Fixes for Windows 7

    Also make sure that the value NeverShowExt is set under HKEY_LOCAL_MACHINE\SOFTWARE\Classes\LnkFile

    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Sunday, March 27, 2011 12:42 PM
  • Checked this out, but the NeverShowExt is already set there. But thanks.

    Or is this a new virus protection of the SP1, that a shortcut now shows the name and the extension, because I didn't changed nothing in the registry in the last time. It doesn't hurt, because all shortcuts run fine, but I have to re-edit the text of every new one.

    Sunday, March 27, 2011 2:30 PM
  • I just checked my systems (one running Windows 7 SP1 and another without SP1) and observations are the same. Looks like it's absolutely normal.

    Perhaps you had the setting "Hide extensions for known file types" enabled previously, and lately you had unchecked it? That might be causing the difference.

     


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Cloud_TS Thursday, March 31, 2011 9:04 AM
    Monday, March 28, 2011 2:34 PM
    Answerer