locked
Remote Tools Notebooks "Workgroup" -Access is denied RRS feed

  • Question

  • I am having an issue running Remote Tools on a notebook. 

    I enter the local user name on the workgroup machine and the password but I get an access is denied error.

     I tried to solve the problem using the information in the following post, but with no success. http://social.technet.microsoft.com/forums/en-US/configmgrgeneral/thread/55291c94-4d34-4c0f-aebf-2a234e143f7a

    I get the following error message in the Eventlog:

    The application-specific permission settings do not grant Remote Activation permission for the COM Server application with CLSID
    {126C0D0F-1F6E-4BD2-A805-B9343F6D8FB5}
     and APPID
    {ACB81998-AAC3-45C1-ADB8-8784CE73A857}
     to the user ...........\Administrator SID (S-1-5-21-991224940-1841376081-1175140746-500) from address 10.20.xx.xx. This security permission can be modified using the Component Services administrative tool.

    Any ideas?

    Thanx

    Friday, June 1, 2012 9:09 AM

Answers

  • Pictop,

    Sounds like a single machine issue.  I'm going off the top of my head here, but do the following to fix this.

    • Open the Registry Editor
    • Use Find to search for the APPID GUID {ACB81998-AAC3-45C1-ADB8-8784CE73A857}
    • You will find the SMS Remote Tools Server
    • Keep that Key handy.
    • Open Component Services (dcomcnfg).
    • Navigate to Component Services/My Computer/DCOM Config
    • Set the view to Details.
    • In the center pane locate the SMS Remote Tools Server item.  The Application ID should match the one shown above
    • Right click on the SMS Remote Tools Server item and select Properties
    • Select the Security tab in the properties dialog
    • In the Launch and Activation frame select Customize and click the Edit button
    • Grant Remote Activation for the ........\Administrator account

    If the security settings are greyed out then you'll have to take ownership of the registry key mentioned above and give the account you are logged in as permissions to the key.  I'm not sure if you'll run into this with any flavor of Windows 7, but I've seen it on Server 2008 R2.

    This should resolve the DCOM issue you are seeing in the Event Viewer and resolve your issue.


    John DeVito


    • Edited by John DeVito Friday, July 6, 2012 1:14 PM
    • Marked as answer by Pictop Monday, July 9, 2012 9:23 AM
    Friday, July 6, 2012 1:13 PM

All replies

  • What is the OS ver....


    Tushar

    Wednesday, June 27, 2012 12:26 PM
  • Windows 7 Enterprise Version 6.1 Build 7601
    Wednesday, June 27, 2012 1:10 PM
  • if possible share with the screenshot.......
    Thursday, June 28, 2012 7:02 AM
  • Hi,

    please find attached some screenshots. I hope this may help you. Please let me know if you need more information.

    www.ImageBanana.com - Capture2.PNG www.ImageBanana.com - Capture1.PNG
    www.ImageBanana.com - Capture.PNG
    • Edited by Pictop Friday, June 29, 2012 7:09 AM
    Friday, June 29, 2012 7:00 AM
  • image is not opening properly..................

    Tushar

    Friday, July 6, 2012 5:44 AM
  • http://www.imagebanana.com/view/ezqpq8wu/Capture1.PNG

    http://www.imagebanana.com/view/9outtzka/Capture2.PNG

    http://www.imagebanana.com/view/gkh3zf33/Capture.PNG

    Friday, July 6, 2012 7:27 AM
  • Pictop,

    Sounds like a single machine issue.  I'm going off the top of my head here, but do the following to fix this.

    • Open the Registry Editor
    • Use Find to search for the APPID GUID {ACB81998-AAC3-45C1-ADB8-8784CE73A857}
    • You will find the SMS Remote Tools Server
    • Keep that Key handy.
    • Open Component Services (dcomcnfg).
    • Navigate to Component Services/My Computer/DCOM Config
    • Set the view to Details.
    • In the center pane locate the SMS Remote Tools Server item.  The Application ID should match the one shown above
    • Right click on the SMS Remote Tools Server item and select Properties
    • Select the Security tab in the properties dialog
    • In the Launch and Activation frame select Customize and click the Edit button
    • Grant Remote Activation for the ........\Administrator account

    If the security settings are greyed out then you'll have to take ownership of the registry key mentioned above and give the account you are logged in as permissions to the key.  I'm not sure if you'll run into this with any flavor of Windows 7, but I've seen it on Server 2008 R2.

    This should resolve the DCOM issue you are seeing in the Event Viewer and resolve your issue.


    John DeVito


    • Edited by John DeVito Friday, July 6, 2012 1:14 PM
    • Marked as answer by Pictop Monday, July 9, 2012 9:23 AM
    Friday, July 6, 2012 1:13 PM
  • Hi John DeVito,

    thank you for your advice, it was very helpful! Unfortunately now I'm getting the following error message:

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
    {174106DC-A50A-4813-A7DE-1CBADAB2A4D9}
     and APPID
    {DD5DF216-F0EE-4C25-A4D0-DF880093B89E}
     to the user ****6025SEV\Administrator SID (S-1-5-21-1790233280-1462117898-3706787740-500) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool

    Should I just repeat the same procedure as above using the APPID indicated in the error message?

    Kind regards,

    Pictop


    • Edited by Pictop Monday, July 9, 2012 9:10 AM
    Monday, July 9, 2012 9:10 AM
  • Hi John DeVito,

    I repeat this procedure and it is working now.

    Thank you!!!!!!!!!!

    Monday, July 9, 2012 9:23 AM
  • I'm glad it worked for you :-)

    John DeVito

    Monday, July 9, 2012 12:08 PM