locked
Multiple activities added to default Standard Change Request after creation and workflow errors RRS feed

  • Question

  • The Standard Change Request has three manual activities added when a new change request is created.  Below errors found in Operations Manager Event Log.

    Only changes were upgrading to SP1.

    Created new Template for Change Request without adding activities.  When I then created a new change request using this template, two manual activites showed up.  One in Pending and one in In Progress.  Where did they come from?  Why are there two if any?  Why do they have different statuses?  And, how is this supposed to be used to resolve the change request? 

     

     

    A Windows Workflow Foundation workflow failed during execution.

     

    Workflow Type: Microsoft.EnterpriseManagement.ServiceManager.ChangeManagement.Workflows.ActivityStatusChangedWorkflow

    Workflow Identifier: ffc10761-6fe9-6442-65db-964d319a96fb

    Exception Type: System.NullReferenceException

    Exception Message: Object reference not set to an instance of an object.

    Exception Stack: at Microsoft.EnterpriseManagement.ServiceManager.ChangeManagement.Workflows.ActivityStatusChangedWorkflow.FindFirstReadyActivity(EnterpriseManagementObject[] activities)

    at Microsoft.EnterpriseManagement.ServiceManager.ChangeManagement.Workflows.ActivityStatusChangedWorkflow.processActivityStatusChangeActivity_ExecuteCode(Object sender, EventArgs e)

    at System.Workflow.ComponentModel.Activity.RaiseEvent(DependencyProperty dependencyEvent, Object sender, EventArgs e)

    at System.Workflow.Activities.CodeActivity.Execute(ActivityExecutionContext executionContext)

    at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)

    at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)

    at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)

    at System.Workflow.Runtime.Scheduler.Run()


    JoeyD
    Friday, December 17, 2010 9:47 PM

Answers

  • Hi

    After being in contact with Travis and one of his true guru's, the solution was very simple; when you create the initial workflow, do not select "Apply a template". Even though it seems logical (at least to me) that I should select which template the workflow was ment for, don't apply any template. That is taken care of already.

     

    Regards,

    Arne

    Tuesday, April 5, 2011 5:37 PM

All replies

  • Hi JDAllen,

    I am facing same Problem what you faced.

    Please let me know if you get any solutions.

     

    Thanks & Regards

    Rajhans,  Sr. Project Executive, P C Solutions Pvt. Ltd. India

    Tuesday, February 1, 2011 5:56 AM
  • Hi

    I have exact the same issue. We use SP1 at the moment

    These extra activities appear without prefix under activites in the console (ie without MA or RA-prefix)

    Is this a bug related to SP!?

     

    Regards,

    Arne

    Friday, March 11, 2011 5:53 PM
  • Hi

    Have you found a solution to this problem?

    Regards,

    Arne

    Friday, April 1, 2011 12:46 PM
  • Hi

    After being in contact with Travis and one of his true guru's, the solution was very simple; when you create the initial workflow, do not select "Apply a template". Even though it seems logical (at least to me) that I should select which template the workflow was ment for, don't apply any template. That is taken care of already.

     

    Regards,

    Arne

    Tuesday, April 5, 2011 5:37 PM
  • Hi Arne,

    I'm still getting this error.

    Thursday, June 21, 2012 4:41 AM