locked
Server Manager Server 2008 R2 Last Refresh Failed RRS feed

  • Question

  • I've been looking at this problem for a few days now trying to figure out why this error appears or how I can solve it but failed..

    Server manager gives the following error :
    Unexpected error refreshing Server Manager: The remote procedure call failed. (Exception from HRESULT: 0x800706BE)

    At first I thought it was the same failure as with server 2008 a while ago so started by using the SUR tool but that gave me the following result:

    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7600.20532
    Package Version 6.0
    2010-01-27 21:06

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store

    Summary:
    Seconds executed: 417
     No errors detected
    Customer Experience report successfully uploaded.  Thank you for participating.  For more information, see the Microsoft Customer Experience Improvement Program on the Microsoft web site.

    So No errors, no missing NUM files nothing.. ok.. looking at the servermanager.log reveals the following:

    2288: 2010-01-27 21:05:52.446 [Provider]                  C:\Windows\system32\ServerManager\Cache\CbsUpdateState.bin does not exist.
    2288: 2010-01-27 21:05:52.759 [CBS]                       IsCacheStillGood: False.
    2288: 2010-01-27 21:06:08.665 [CBS] Error (Id=0) Function: 'CreateSessionAndPackage()->Session_OpenPackage' failed: 800706be (-2147023170)
    2288: 2010-01-27 21:06:09.353 [ExceptionHandler] Error (Id=0) An unexpected exception was found:
    System.Runtime.InteropServices.COMException (0x800706BE): The remote procedure call failed. (Exception from HRESULT: 0x800706BE)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
       at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
       at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
       at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
       at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
       at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
       at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

    Looked here in the forum for solutions but most of the people had NUM files missing or other errors. I've tried copying the missing cache files from another server to the cache diretory but these files are deleted by server manager on the next refresh:

    1684: 2010-01-27 21:00:48.325 [CBS]                       LastModified CBS Time (UTC): 01/26/2010 20:57:31
    1684: 2010-01-27 21:00:48.325 [CBS]                       Cache Last Write Time (UTC): 01/26/2010 19:25:41
    1684: 2010-01-27 21:00:48.325 [CBS]                       IsCacheStillGood: False.
    1684: 2010-01-27 21:00:58.013 [CBS] Error (Id=0) Function: 'CreateSessionAndPackage()->Session_OpenPackage' failed: 800706be (-2147023170)

    also the CBS.log gives there errors
    2010-01-27 19:10:05, Info                  CBS    Failed to get session package state for package: Package_2_for_KB974431~31bf3856ad364e35~amd64~~6.1.1.5 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2010-01-27 19:10:05, Info                  CBS    Failed to get session package state for package: Package_2_for_KB975467~31bf3856ad364e35~amd64~~6.1.1.0 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2010-01-27 19:10:05, Info                  CBS    Failed to get session package state for package: Package_2_for_KB972270~31bf3856ad364e35~amd64~~6.1.1.0 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

    So i've downloaded those packages, renamed them to cab,  extracted the cab file to another directory and extracted the new cab file again to a temporary directory, then copied the extracted files to the windows\servicing\packages directory. I've copied the manifest to the winsxs\manifests directory and the other files to the services\packages directory.

    Rebooted server, waited for server manager to come up again but still same error:
    Unexpected error refreshing Server Manager: The remote procedure call failed. (Exception from HRESULT: 0x800706BE)

    Checked the registry for corrupted settings :
    1. HKLM\Software\Microsoft\Windows\CurrentVersion\SideBySide\@CorruptPendingXml (REG_SZ)
    2. HKLM\Software\Microsoft\Windows\CurrentVersion\SideBySide\@CorruptPendingXmlIdentifiers (REG_SZ)

    But both keys had no @corrupted entries or what so ever..

    Anyone has other suggestions?

    • Changed type Tim Quan Friday, January 29, 2010 1:28 AM
    Wednesday, January 27, 2010 8:39 PM

Answers

  • Hi,

     

    Please download the files from the following site and then copy them to C:\Windows\servicing\Packages.

     

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=b356e40d-50ee-467b-ad03-5cc8b3c078fb

    Password: esed{O78ZKpyI

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    • Marked as answer by Tim Quan Friday, January 29, 2010 1:28 AM
    Thursday, January 28, 2010 8:05 AM
  • Thanks Tim!

    result is that there is now a different error so it helps :)

    ok Current error in server manager log:

    2328: 2010-01-28 09:56:17.525 [CBS]                       LastModified CBS Time (UTC): 01/28/2010 02:08:18
    2328: 2010-01-28 09:56:17.572 [CBS]                       Cache Last Write Time (UTC): 07/14/2009 05:06:40
    2328: 2010-01-28 09:56:17.572 [CBS]                       IsCacheStillGood: False.
    2328: 2010-01-28 09:56:25.384 [CBS]                       >>>GetUpdateInfo--------------------------------------------------
    2328: 2010-01-28 09:56:26.431 [CBS] Error (Id=0) Function: 'ReadUpdateInfo()->Update_GetProperty' failed: 80070543 (-2147023549)
    2328: 2010-01-28 09:56:26.431 [CBS]                       <<<GetUpdateInfo--------------------------------------------------

    CBS.log

    2010-01-28 09:56:26, Info                  CBS    Failed to get user security token [HRESULT = 0x80070543 - ERROR_CANT_OPEN_ANONYMOUS]
    2010-01-28 09:56:26, Info                  CBS    Failed to get user token. [HRESULT = 0x80070543 - ERROR_CANT_OPEN_ANONYMOUS]

    But I had changed the component security to none (found that in this forum too) changed that back to connect and server refresh works fine now!

    thanks for your assistance!
    • Marked as answer by Tim Quan Friday, January 29, 2010 1:28 AM
    Thursday, January 28, 2010 9:33 AM

All replies

  • Hi,

     

    Please download the files from the following site and then copy them to C:\Windows\servicing\Packages.

     

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=b356e40d-50ee-467b-ad03-5cc8b3c078fb

    Password: esed{O78ZKpyI

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    • Marked as answer by Tim Quan Friday, January 29, 2010 1:28 AM
    Thursday, January 28, 2010 8:05 AM
  • Thanks Tim!

    result is that there is now a different error so it helps :)

    ok Current error in server manager log:

    2328: 2010-01-28 09:56:17.525 [CBS]                       LastModified CBS Time (UTC): 01/28/2010 02:08:18
    2328: 2010-01-28 09:56:17.572 [CBS]                       Cache Last Write Time (UTC): 07/14/2009 05:06:40
    2328: 2010-01-28 09:56:17.572 [CBS]                       IsCacheStillGood: False.
    2328: 2010-01-28 09:56:25.384 [CBS]                       >>>GetUpdateInfo--------------------------------------------------
    2328: 2010-01-28 09:56:26.431 [CBS] Error (Id=0) Function: 'ReadUpdateInfo()->Update_GetProperty' failed: 80070543 (-2147023549)
    2328: 2010-01-28 09:56:26.431 [CBS]                       <<<GetUpdateInfo--------------------------------------------------

    CBS.log

    2010-01-28 09:56:26, Info                  CBS    Failed to get user security token [HRESULT = 0x80070543 - ERROR_CANT_OPEN_ANONYMOUS]
    2010-01-28 09:56:26, Info                  CBS    Failed to get user token. [HRESULT = 0x80070543 - ERROR_CANT_OPEN_ANONYMOUS]

    But I had changed the component security to none (found that in this forum too) changed that back to connect and server refresh works fine now!

    thanks for your assistance!
    • Marked as answer by Tim Quan Friday, January 29, 2010 1:28 AM
    Thursday, January 28, 2010 9:33 AM
  • Hi,

    I am glad to hear that this issue has been resolved.

    Tim Quan - MSFT
    Friday, January 29, 2010 1:28 AM
  • I have the same error how can I fix it?

    Thanks
    Friday, February 19, 2010 3:05 PM
  • I am having the same error how can I get access the \packages replacement files. In the server manager the error is "Unexpected error refreshing Server Manager: The remote procedure call failed..." Thanks.
    Thursday, March 18, 2010 1:25 PM
  • please put file for mi
    Averin_Eugene
    Thursday, March 25, 2010 12:45 PM
  • Seeing the same issue. Please repost an updated version of the link...
    Friday, March 26, 2010 11:16 PM
  • The download link above does not work.

    I get the following message:

    "No workspace was found corresponding to the supplied password. The password or web page address (URL) may be incorrect. Please verify the password with a Microsoft Support Professional."


    -- With Regards Shailen Sukul Software Architect/Developer/Consultant/Trainer (BSc | Mct | Mcpd | Mcts (Sharepoint, Biztalk, Web, Win, Dist Apps) | Mcsd.NET | Mcsd | Mcad) MSN | Skype | GTalk Id: shailensukul Blog: http://shailen.sukul.org
    • Proposed as answer by Koko-Roxo Monday, April 12, 2010 7:49 AM
    Thursday, April 1, 2010 1:26 AM
  • Dear Tim Quan,

     

    Would you be kind enough to get us a new link with the files that you beleive that may fix a similar problem.

     

    Kind regards Peao_d_luxo

    Monday, April 12, 2010 7:51 AM
  • Hi All,

     

    To reduce confusions, please post new threads to request the files.

     

    Tim Quan - MSFT

    Tuesday, April 13, 2010 4:04 AM
  • I have same issue please  give link for files, thanks
    Saturday, August 21, 2010 5:56 AM
  • I am also having he same  problem with Server Manager R2, help is needed.
    Sunday, August 22, 2010 9:06 PM
  • Tim,

    I am having this same issue.  Can you please post the link for me to download the file?

    My new thread is as follows:

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/276cd9d3-e1d5-4b11-a01b-39e612fe3680

    Can you please provide link for resolution?

    Thanks.


    President, MTS Consulting Group
    Thursday, September 2, 2010 4:42 PM
  • If so many people are having this problem (I have it also), why is this file not available generally?
    Friday, October 15, 2010 11:37 PM
  • If so many people are having this problem (I have it also), why is this file not available generally?

    I have to ask the same question, we are also experiencing this error on out TFS 2010 server which is running Windows Server 2008 R2.

    Regards

    Iain Herdman

    Release Manager

    iFACTS AB

    Monday, October 18, 2010 1:36 PM
  • I have what seems to be exactly the same issue,that commenced yesterday following the application of 21 patches to Windows 2008R2 (see http://social.microsoft.com/Forums/en-US/partnerwinserver7rcthreads/thread/a0ecaee9-0fd9-49a1-8c45-087ac0db5540 for details).

     

    Can Microsoft provide a more robust solution as it does appear that this issue is now becoming a common one?


    Chris Jones Mollington Consultants Limited
    Saturday, October 23, 2010 10:34 AM
  • Hi,

    I have the same error in win2008 x64 R2.

    Could you give me the files through the same way? With the password off course? :)

    If not, because I have another server installed but is working fine, could you point me to the files from, c:\windows\servicing\Packages, where I can copying on my machine?

    Best regards,

    catalin

     

    Thursday, November 25, 2010 10:31 AM
  • The following KB article talks about resolution for this problem.

    http://support.microsoft.com/kb/947821

    Thursday, October 20, 2011 5:28 AM