none
Free Busy Information RRS feed

  • Question

  • I am running Exchange 2007 on Server 08.  I have all the patches for windows and exchange applied. I can not see the free busy information of other users in my directory.  BUT only when accessing with http over rpc.  Connecting to OWA works fine, connecting with the client (either Outlook 07 or 2010) through either VPN or LAN is fine.  I was thinking it has something to do with the web services but doesn't OWA use the EWS ??  NOt sure where to look.  Need Help Please. 
    Tuesday, July 12, 2011 2:53 AM

All replies

  • Do you have a proxy in your network for all Internet communications?
    Tuesday, July 12, 2011 5:22 AM
  • Yes. OWA now also calls the availability service API which reads free/busy information from the target mailbox, but the procedure is a little difference. Outlook Anywhere client should involve Autodiscover to obtain the Availability Service URL.

     

    At this stage, please perform the following steps to check whether Autodiscover information can be detected successfully.

     

    1. While Outlook is running, hold down the CTRL key, right-click the Outlook icon in the notification area, and then select Test E-mail AutoConfiguration.

    2. Verify that the correct e-mail address is in the box next to E-mail Address.

    3. Clear the check boxes next to Use Guessmart and Secure Guessmart Authentication.

    4. On the Test E-mail AutoConfiguration page, verify that the check box next to Use AutoDiscover is selected, and then click the Test button.

    5. Then, please post the Result tab and Log tab here for research.

     

    Also, please run the following command and post the result here.

     

    get-webservicesfirtualdirectory | FL

     

    Thanks.

    Novak Wu

    Wednesday, July 13, 2011 6:21 AM
  • Here are the results of the get-webservicesvirtualdirectory  I will post the rest after I capture later  Thanks for your help

     

     

     

    InternalNLBBypassUrl          : https://ex2007.aisxxx.xxx/ews/exchange.asmx
    Name                          : EWS (Default Web Site)
    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    BasicAuthentication           : False
    DigestAuthentication          : False
    WindowsAuthentication         : True
    MetabasePath                  : IIS://ex2007.aisxxx.xxx/W3SVC/1/ROOT/EWS
    Path                          : C:\Program Files\Microsoft\Exchange Server\Clie
                                    ntAccess\exchweb\EWS
    Server                        : EX2007
    InternalUrl                   : https://ex2007.aisxxx.xxx/EWS/Exchange.asmx
    ExternalUrl                   :
    AdminDisplayName              :
    ExchangeVersion               : 0.1 (8.0.535.0)
    DistinguishedName             : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,
                                    CN=EX2007,CN=Servers,CN=Exchange Administrative
                                     Group (FYDIBOHF23SPDLT),CN=Administrative Grou
                                    ps,CN=AIS,CN=Microsoft Exchange,CN=Services,CN=
                                    Configuration,DC=aisdom,DC=tld
    Identity                      : EX2007\EWS (Default Web Site)
    Guid                          : 001e13d2-2445-4959-b8e5-0dfb81c4d29e
    ObjectCategory                : aisdom.tld/Configuration/Schema/ms-Exch-Web-Ser
                                    vices-Virtual-Directory
    ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
                                    VirtualDirectory}
    WhenChanged                   : 6/12/2009 11:59:59 AM
    WhenCreated                   : 6/12/2009 11:59:35 AM
    OriginatingServer             : atdc4.at.aisdom.tld
    IsValid                       : True

    Wednesday, July 13, 2011 7:16 PM
  • Your external URL is not set.  Set this and test.
    Sukh
    Wednesday, July 13, 2011 7:54 PM
  •  

     

    All it would let me capture sorry

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Jeff Schaefer</DisplayName>
          <LegacyDN>/o=AIS/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=jschaefer</LegacyDN>
          <DeploymentId>e77368af-7e41-497a-b271-2b90bbe77efa</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>ex2007.aisdom.tld</Server>
            <ServerDN>/o=AIS/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EX2007</ServerDN>
            <ServerVersion>720280B0</ServerVersion>
            <MdbDN>/o=AIS/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EX2007/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>ex2007.aisdom.tld</PublicFolderServer>
            <AD>atdc3.at.aisdom.tld</AD>
            <ASUrl>https://ex2007.aisdom.tld/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://ex2007.aisdom.tld/EWS/Exchange.asmx</EwsUrl>
            <OOFUrl>https://ex2007.aisdom.tld/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://ex2007.aisdom.tld/UnifiedMessaging/Service.asmx</UMUrl>
            <OABUrl>Public Folder</OABUrl>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>owa.thinkapplied.com</Server>
            <SSL>On</SSL>
            <AuthPackage>Basic</AuthPackage>
            <OABUrl>Public Folder</OABUrl>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <External>
              <OWAUrl AuthenticationMethod="Fba">https://owa.thinkapplied.com/owa</OWAUrl>
            </External>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Fba">https://owa.thinkapplied.com/owa</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://ex2007.aisdom.tld/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
          </Protocol>
        </Account>
      </Response>
    </Autodiscover>

    Wednesday, July 13, 2011 7:56 PM
  • Try Set-WebServicesVirtualDirectory -identity "CAS01\EWS (Default Web Site)" -externalurl https://mail.contoso.com/EWS/Exchange.asmx

    Replace the external url with https://owa.thinkapplied.com/EWS/Exchange.asmx 

    And the -identity where the CAS01 is with your Exch servername, which looks like exch2007.

    You may have to restart IIS after,

     

     


    Sukh
    Wednesday, July 13, 2011 8:51 PM
  • this command and a reboot (had to apply a couple of patches) worked  Thanks
    Tuesday, July 19, 2011 3:06 PM