none
Deny Users' from creating files and folders in Document Library root

    Question

  • Hi,

    I'm fairly new to SharePoint Online, but have managed to setup a site with a few folders in the document library as per below:

    My Site

    Document Library

    • Folder1
    • Folder2
    • Folder3

    I have set the permissions on each folder, but and stuck at where I deny users' from creating items(folder and files) in the Document library root.

    How do I accomplish this?

    thanks,

    Fulton.


    Have a good day.

    Friday, February 24, 2017 4:38 AM

Answers

  • Hi,

    Looks you have stopped inheriting permission from parent to newly created folder and granted unique  access to required users. 

    Check your library permission by navigating to library permission settings. If your library inheriting permission from parent then check parent site groups and its permission.

    Make sure that users are added in the the group which has minimum contribute access. If not then created  a new group with contribute access and add users those who want to contribute in document library.

    Hope this will helps you.


    Senthilrajan Kaliyaperumal

    • Marked as answer by Fultz Friday, February 24, 2017 5:42 AM
    Friday, February 24, 2017 5:12 AM

All replies

  • Hi,

    Looks you have stopped inheriting permission from parent to newly created folder and granted unique  access to required users. 

    Check your library permission by navigating to library permission settings. If your library inheriting permission from parent then check parent site groups and its permission.

    Make sure that users are added in the the group which has minimum contribute access. If not then created  a new group with contribute access and add users those who want to contribute in document library.

    Hope this will helps you.


    Senthilrajan Kaliyaperumal

    • Marked as answer by Fultz Friday, February 24, 2017 5:42 AM
    Friday, February 24, 2017 5:12 AM
  • Thanks mate.

    Have a good day.

    Friday, February 24, 2017 5:43 AM