none
Windows 10 - gpresult /r does not list user group memberships

    General discussion

  • On a Windows 10 Client (threshold 2) gpresult fails to show user group memberships.

    Username, Domain name and OU are listed correctly.

    gpresult /r says "unexpected error" (FEHLER: Ein unerwarteter Fehler ist aufgetreten.)

    In a html report built with gpresult /h all the settings are shown correctly but the list of security group memberships is just empty.

    whoami /groups lists all the groups correctly but not gpresult.

    Friday, November 27, 2015 10:58 AM

All replies

  • Hi woodrapp,

    Is the Windows 10 client newly added to domain ? Have you tried to log off and then logon again?

    Please give it a try and let us know the result.  


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 30, 2015 8:19 AM
    Moderator
  • Hi

    The client is prestaged in active directory and setup by WDS 2012.

    We had a similar issue with windows 10 prior to 1511. That was fixed by disableing unc path hardening.
    Now with 1511 the trouble is back.

    The client behaves as follows:
    After wds install image is applied and windows setup has run, the client performs autologon with a domain account. autologon is defined in oobesystem section in unattend.xml.

    with windows 10 prior to 1511 the user would logon, gpo would be applied and logon script would always be launched.

    Now with 1511 the user logs on automatically ok,  but user gpo is not applied and therefore logon script would not start.
    gpresult /r says sth like user has no RSoP Data.

    Client then performs reboot and autologon again.
    Now GPO are applied but gpresult /r still fails to list group memberships, while OUs are listet correclty, see image:

    After manually running gpupdate /force domain name and type are reportet ok, but still there are no user groups listed.
    • Edited by woodrapp Monday, November 30, 2015 1:26 PM
    Monday, November 30, 2015 12:16 PM
  • Hi woodrapp,

    Is the issue only happening on Windows 10 system? Have you ever tried the same command on other Operation Systems?

    Also, does this happen to all users or this specific user account? Try to check with another user account and see if issue persists.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 1, 2015 9:29 AM
    Moderator
  • Here's what I discovered:

    If a default printer is set via user gpo, gpo is NOT applied upon first automatic login after windows setup and gpresult says "No RSoP-Data".
    When the client then restarts and the user logs in again, gpo would be applied but gpresult would still fail to list group memberships.

    If NO default printer is set via user gpo, everything works fine.

    So, I unchecked "set as default printer" in the user gpo and now I can deploy windows 10 1511 with WDS.

    Eventviewer shows multiple entries of events 7031 and 7032 in System log.

    Pls note that this behaviour does not occur when I install windows 10 build 10240 (before 1511).



    • Edited by woodrapp Monday, December 7, 2015 3:06 PM
    Monday, December 7, 2015 8:14 AM
  • Hi woodrapp,

    Appreciate your update.

    According to your test, I would agree that it might be a issue of Windows 10 build . You could submit the feedback via Windows feedback App in Windows 10. Windows 10 product team will take notice of your feedback.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 8, 2015 7:24 AM
    Moderator
  • Hi 

    I got no answer from MS.

    I keep getting "Not applicable" from gpresult /r, as soon as I activate "Set this printer as the default printer" in the user gpo.

    The user is part of the following security groups
    -----------------------------------------------------
    Not applicable


    • Edited by woodrapp Monday, December 14, 2015 3:10 PM
    Monday, December 14, 2015 3:09 PM