locked
Linux Integration Service Update Required RRS feed

  • Question

  • Hi All,

    I have a VM setup running CentOS7 which I use for a few services which works OK.

    I am looking to backup this VM using Backup Assist the same way as I do with my Windows VMs. The backup fails and I believe it was due to LIS not being installed. I have now installed LIS but it still fails. I also noticed that under the Hypervisor the VM has a message that says that an update is required for the Integration Service. I am currently running LIS 4.1.

    Any ideas?

    • Moved by BrianEhMVP Friday, April 15, 2016 3:22 PM
    Friday, April 15, 2016 3:30 AM

All replies

  • How about doing simple steps, the KISS method:

    1. Shut down the virtual machine
    2. Export the Virtual Machine and/or Copy the .VHD files

    https://blogs.technet.microsoft.com/kevinremde/2012/02/21/how-to-cheaply-backup-virtual-machines-so-many-questions-so-little-time-part-14/


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    • Proposed as answer by Leo Han Wednesday, April 27, 2016 9:30 AM
    Friday, April 15, 2016 5:45 AM
  • Hi Matt,

    >>I am looking to backup this VM using Backup Assist the same way as I do with my Windows VMs.

    Have you contacted the technical support of Backup Assist to see if linux vm needs any other settings?

    https://www.backupassist.com/support/contact.html

    >>I have now installed LIS but it still fails.

    Is there any error message in the backup application?

    If yes, you could contact its technical support to troubleshoot.

    >>I am currently running LIS 4.1

    As far as I know, it is the latest version.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 15, 2016 6:02 AM
  • I have seen the HyperV gui misreport with centos7 that an update is required.

    It should show the correct version from cmd line and from the cluster gui. (At least it does for me.)

    Get-VM | ft Name, IntegrationServicesVersion

    I would confirm that you do have a healthy and current install of 4.1 first.

    -Jay

    Monday, April 18, 2016 3:10 PM
  • The version check message does not apply to Linux VMs, you can ignore it.

    Thanks, --jrp


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Thursday, April 28, 2016 9:03 PM