none
Office 2010 can not contact AD RMS licensing service. RRS feed

  • Question

  • We installed AD RMS and it works fine with Office 2007.

    Some users use Office 2010 and they can not open protected files and Outlook messages with error "License Service is temporarily unavailable"

    I've tracked this problem and found Office 2010 made a registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\DRM\ServiceLocations]

    "8|2|https://mydomain/_wmcs/licensing"="https://mydomain/licensing"

    But the real URL to licensing service is https://mydomain/_wmcs/licensing

    SCP configured correctly...

    I changed this key but it continued switching back until i closed Outlook.

    After closing Outlook and correcting that key everything goes fine.

    Is it bug or feature of Office 2010?

    Thursday, April 5, 2012 8:48 AM

Answers

  • Hi vden,

    have you figured out what was going on with the registry entry?

    Do you have an GPO in place to update the registry entry?

    Do you have recently changed the cluster URL?

    Thank you,

    Lutz

    • Proposed as answer by LutzMH Friday, July 27, 2012 3:44 PM
    • Marked as answer by vden Tuesday, September 18, 2012 1:58 PM
    Friday, July 27, 2012 3:44 PM
  • Hi LutzMH. 

    Yes. The cause of my trouble was GPO. It's funny that  i had made it myself some time before %)

    And it's still strange for me that i have to make a GPO to connect Office 2010 clients while those with Office 2007 work fine without any GPO.

    Correct ADM file looks like that (file last symbol should be "return"):

    CLASS USER CATEGORY "ADRMS_OFFICE2010" POLICY "ADRMS_OFFICE2010" KEYNAME Software\Policies\MyDomain VALUENAME ADRMS_OFFICE2010 VALUEON NUMERIC 1 VALUEOFF NUMERIC 0 ACTIONLISTON KEYNAME "Software\Microsoft\Office\14.0\Common\DRM\ServiceLocations" VALUENAME "8|2|https://adrms.mydomain/_wmcs/licensing" VALUE "https://adrms.mydomain/_wmcs/licensing" END ACTIONLISTON ACTIONLISTOFF KEYNAME "Software\Microsoft\Office\14.0\Common\DRM\ServiceLocations" VALUENAME "8|2|https://adrms.mydomain/_wmcs/licensing" VALUE "https://adrms.mydomain /licensing" END ACTIONLISTOFF END POLICY END CATEGORY



    • Marked as answer by vden Tuesday, September 18, 2012 1:58 PM
    • Edited by vden Tuesday, September 18, 2012 2:03 PM
    Tuesday, September 18, 2012 1:57 PM

All replies

  • Hi vden,

    have you figured out what was going on with the registry entry?

    Do you have an GPO in place to update the registry entry?

    Do you have recently changed the cluster URL?

    Thank you,

    Lutz

    • Proposed as answer by LutzMH Friday, July 27, 2012 3:44 PM
    • Marked as answer by vden Tuesday, September 18, 2012 1:58 PM
    Friday, July 27, 2012 3:44 PM
  • Hi LutzMH. 

    Yes. The cause of my trouble was GPO. It's funny that  i had made it myself some time before %)

    And it's still strange for me that i have to make a GPO to connect Office 2010 clients while those with Office 2007 work fine without any GPO.

    Correct ADM file looks like that (file last symbol should be "return"):

    CLASS USER CATEGORY "ADRMS_OFFICE2010" POLICY "ADRMS_OFFICE2010" KEYNAME Software\Policies\MyDomain VALUENAME ADRMS_OFFICE2010 VALUEON NUMERIC 1 VALUEOFF NUMERIC 0 ACTIONLISTON KEYNAME "Software\Microsoft\Office\14.0\Common\DRM\ServiceLocations" VALUENAME "8|2|https://adrms.mydomain/_wmcs/licensing" VALUE "https://adrms.mydomain/_wmcs/licensing" END ACTIONLISTON ACTIONLISTOFF KEYNAME "Software\Microsoft\Office\14.0\Common\DRM\ServiceLocations" VALUENAME "8|2|https://adrms.mydomain/_wmcs/licensing" VALUE "https://adrms.mydomain /licensing" END ACTIONLISTOFF END POLICY END CATEGORY



    • Marked as answer by vden Tuesday, September 18, 2012 1:58 PM
    • Edited by vden Tuesday, September 18, 2012 2:03 PM
    Tuesday, September 18, 2012 1:57 PM
  • Hi vden,

    Office 2010 clients should go to the SCP and get the URL in the same way Office 2007 is doing this.

    I do not see a reason why Office 2010 should "eat" _wmcs from the URL string.

    Best,

    Lutz

    Tuesday, September 18, 2012 2:18 PM