locked
W7 & Vista: Videos are brighter than they should be, please help / explain RRS feed

  • Question

  • Hey guys, I am running a nVidia 7600 GT video card with the W7 preview drivers installed and have been noticing some problems with video brightness.  I have also seen these issues in Vista and it's one of the main reasons I still use XP (which doesn't cause me this issue). 

    With the following nVidia Control Panel Settings ...

    Display / Adjust desktop color settings - set to default values

    - Brightness / Contrast / Gamma: 50%
    - Digital Vibrance / Image Sharpening: 0%

    Display / Adjust video color settings

    - With the video player settings

    GOM Player (DirectX rendering modes) or VLC (default rendering mode): My videos appear brighter than they normally are, and with less contrast.  This is easy to see because black appears as a dark grey and the definition is gone from the whites. 

    Windows Media Player / GOM Player (video renderer modes): Videos appear as expected

    With the following nVidia Control Panel Settings ...

    Display / Adjust desktop color settings - set to default values

    - as above

    Video & Television  / Adjust video color settings

    - With the NVIDIA settings (default values)
    - Brightness / Contrast / Saturation: 50%
    - Hue: 0%

    Using these "default" settings, I can reproduce the problem in ALL players including Windows Media Player, so it appears that WMP is applying some custom settings to make the videos appear correctly in the previous scenario.

    With the following nVidia Control Panel Settings ...

    Display / Adjust desktop color settings - set to default values

    - as above

    Video & Television / Adjust video color settings

    - With the NVIDIA settings - set to default values
    - Brightness: 42%
    - Contrast: 60%
    - Saturation: 50%
    - Hue: 0%

    I seem to get the original brightness and contrast with all players (WMP, GOM Player and VLC)

    Any assistance as to why this is happening would be appreciated a lot!! :)

    Thanks
    Zambz

    EDIT:

    Under Video & Television  / Adjust video color settings,  on the Advanced tab, if you set the Dynamic Range to Full 0-255 (instead of Limited 16-235), it works perfectly on all players.
    • Edited by zambz-old Monday, May 11, 2009 3:03 AM
    Sunday, May 10, 2009 11:35 AM

Answers

  • Since you managed to solve your own problem, I'll mark this thread answered. Thanks zambz-old :)

    -Nick
    • Proposed as answer by Nick FV Wednesday, June 17, 2009 8:05 PM
    • Marked as answer by axfelix Wednesday, June 17, 2009 9:56 PM
    Wednesday, June 17, 2009 8:05 PM