locked
Some machines erroring on installation of Project and Visio, Log seems generic like there's a time out? RRS feed

  • Question

  • Full disclosure we use the PS App deployment Toolkit with SCCM, and a few machines have had either project 2013 or visio 2013 not able to complete the installation and time out after 40 minutes, I'll post the log Appenforce.log

    Exceeded timeout of 40 minutes while waiting for process 9788 to finish. AppEnforce 11/5/2015 8:18:11 AM 9424 (0x24D0)
    WaitForRunningProcess failed.  Error 0x87d00213. AppEnforce 11/5/2015 8:18:11 AM 9424 (0x24D0)
    CScriptHandler::CompleteEnforcement failed with 0x87d00213 AppEnforce 11/5/2015 8:18:11 AM 9424 (0x24D0)
    CAppProvider::CompleteEnforcement failed with error 0x87d00213 AppEnforce 11/5/2015 8:18:11 AM 9424 (0x24D0)
    ++++++ Failed to enforce app. Error 0x87d00213. ++++++ AppEnforce 11/5/2015 8:18:11 AM 9424 (0x24D0)
    +++ Starting Install enforcement for App DT "Microsoft Visio 2013 SP1" ApplicationDeliveryType - ScopeId_24B34708-2303-4B92-B075-31189DF82E2C/DeploymentType_39d098f0-97fa-493f-88ac-e0ba6d6827a3, Revision - 4, ContentPath - C:\windows\ccmcache\3w, Execution Context - System AppEnforce 11/5/2015 9:11:49 AM 10284 (0x282C)


    Thursday, November 5, 2015 9:38 PM

All replies

  • Do you log the install of Project and Visio as part of their installs? You really must if you are to find out why the installs are timing out.

    Cheers Paul | http://sccmentor.wordpress.com

    Thursday, November 5, 2015 10:14 PM
  • The PS App Deploy Toolkit does really good logging.  By default those logs are written to c:\windows\logs\software.  What do the logs for those installs show?

    Jeff

    Friday, November 6, 2015 5:32 AM
  • Timeouts in ConfigMgr deployments are often the result of the command-line being executed showing UI (either an error or a prompt) that the user cannot respond to because it is not shown on their "desktop". Adding logging can often help identify this as well as testing of the command-line outside of ConfigMgr.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, November 6, 2015 3:12 PM
  • [Initialization] :: PowerShell CLR (.NET) version is [2.0.50727.5485] PSAppDeployToolkit 11/6/2015 8:15:34 AM 8972 (0x230C)
    [Initialization] :: ******************************************************************************* PSAppDeployToolkit 11/6/2015 8:15:34 AM 8972 (0x230C)
    [Initialization] :: Get session information for all logged on users. Get-LoggedOnUser 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Logged on user session details: 


    NTAccount          : AL\GuzmanAX
    UserName           : GuzmanAX
    DomainName         : AL
    SessionId          : 1
    SessionName        : Console
    ConnectState       : Active
    IsCurrentSession   : False
    IsConsoleSession   : True
    IsUserSession      : True
    IsLocalAdmin       : True
    LogonTime          : 11/6/2015 7:19:27 AM
    IdleTime           : 00:00:00
    DisconnectTime     : 
    ClientName         : 
    ClientProtocolType : 
    ClientDirectory    : 
    ClientBuildNumber  : 0



    PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: The following users are logged on to the system: AL\GuzmanAX PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Current process is running under a system account [NT AUTHORITY\SYSTEM] PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: The following user is the console user [AL\GuzmanAX] (user with control of physical monitor, keyboard, and mouse). PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: The process is running in a terminal server session: [False]. PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Unable to load COM Object [Microsoft.SMS.TSEnvironment]. Therefore, script is not currently running from a SCCM Task Sequence. PSAppDeployToolkit 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Service [EventSystem] exists Test-ServiceExists 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Get the service [EventSystem] startup mode. Get-ServiceStartMode 11/6/2015 8:15:39 AM 8972 (0x230C)
    [Initialization] :: Service [EventSystem] startup mode is set to [Automatic] Get-ServiceStartMode 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Get the service object for service [EventSystem] Start-ServiceAndDependencies 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [EventSystem] with display name [COM+ Event System] has a status of [Running] Start-ServiceAndDependencies 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [RpcSs] exists Test-ServiceExists 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Get the service [RpcSs] startup mode. Get-ServiceStartMode 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [RpcSs] startup mode is set to [Automatic] Get-ServiceStartMode 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Get the service object for service [RpcSs] Start-ServiceAndDependencies 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [RpcSs] with display name [Remote Procedure Call (RPC)] has a status of [Running] Start-ServiceAndDependencies 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [EventLog] exists Test-ServiceExists 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Get the service [EventLog] startup mode. Get-ServiceStartMode 11/6/2015 8:15:40 AM 8972 (0x230C)
    [Initialization] :: Service [EventLog] startup mode is set to [Automatic] Get-ServiceStartMode 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Get the service object for service [EventLog] Start-ServiceAndDependencies 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Service [EventLog] with display name [Windows Event Log] has a status of [Running] Start-ServiceAndDependencies 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Service [Schedule] exists Test-ServiceExists 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Get the service [Schedule] startup mode. Get-ServiceStartMode 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Service [Schedule] startup mode is set to [Automatic] Get-ServiceStartMode 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Get the service object for service [Schedule] Start-ServiceAndDependencies 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Service [Schedule] with display name [Task Scheduler] has a status of [Running] Start-ServiceAndDependencies 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: The task scheduler service is in a healthy state: True PSAppDeployToolkit 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Session 0 not detected. PSAppDeployToolkit 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Installation is running in [Interactive] mode. PSAppDeployToolkit 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Initialization] :: Deployment type is [Installation] PSAppDeployToolkit 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Evaluate disk space requirements. Show-InstallationWelcome 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Retrieve free disk space for drive [C:]. Get-FreeDiskSpace 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Free disk space for drive [C:]: [2945 MB]. Get-FreeDiskSpace 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Successfully passed minimum disk space requirement check. Show-InstallationWelcome 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Get deferral history... Get-DeferHistory 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Return fully qualified registry key path [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\PSAppDeployToolkit\DeferHistory\Microsoft_Visio_15.0.4569.1504_EN_01] Convert-RegistryPath 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Registry key [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\PSAppDeployToolkit\DeferHistory\Microsoft_Visio_15.0.4569.1504_EN_01] does not exist Get-RegistryKey 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: User has [0] deferrals remaining. Show-InstallationWelcome 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Check for running application(s) [visio]... Get-RunningProcesses 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Application(s) are not running. Get-RunningProcesses 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Finished checking running application(s). Get-RunningProcesses 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: User has the option to defer. Show-WelcomePrompt 11/6/2015 8:15:41 AM 8972 (0x230C)
    [Pre-Installation] :: Error Record:
    -------------

    Message        : Exception calling "ShowDialog" with "0" argument(s): "Showing 
                     a modal dialog box or form when the application is not running
                      in UserInteractive mode is not a valid operation. Specify the
                      ServiceNotification or DefaultDesktopOnly style to display a 
                     notification from a service application."
    InnerException : System.InvalidOperationException: Showing a modal dialog box o
                     r form when the application is not running in UserInteractive 
                     mode is not a valid operation. Specify the ServiceNotification
                      or DefaultDesktopOnly style to display a notification from a 
                     service application.
                        at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
                        at ShowDialog(Object , Object[] )
                        at System.Management.Automation.DotNetAdapter.AuxiliaryMeth
                     odInvoke(Object target, Object[] arguments, MethodInformation 
                     methodInformation, Object[] originalArguments)

    FullyQualifiedErrorId : DotNetMethodException

    PositionMessage : 
                      At C:\windows\ccmcache\3w\AppDeployToolkit\AppDeployToolkitMa
                      in.ps1:5554 char:36
                      +         $result = $formWelcome.ShowDialog <<<< ()



    Error Inner Exception(s):
    -------------------------

    Message        : Showing a modal dialog box or form when the application is not
                      running in UserInteractive mode is not a valid operation. Spe
                     cify the ServiceNotification or DefaultDesktopOnly style to di
                     splay a notification from a service application.
    InnerException : 



    Deploy Application 11/6/2015 8:15:42 AM 8972 (0x230C)
    [Pre-Installation] :: Display Dialog Box with message: Error Record:
    -------------

    Message        : Exception calling "ShowDialog" with "0" argument(s): "Showing 
                     a modal dialog box or form when the application is not running
                      in UserInteractive mode is not a valid operation. Specify the
                      ServiceNotification or DefaultDesktopOnly style to display a 
                     notification from a service application."
    InnerException : System.InvalidOperationException: Showing a modal dialog box o
                     r form when the application is not running in UserInteractive 
                     mode is not a valid operation. Specify the ServiceNotification
                      or DefaultDesktopOnly style to display a notification from a 
                     service application.
                        at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
                        at ShowDialog(Object , Object[] )
                        at System.Management.Automation.DotNetAdapter.AuxiliaryMeth
                     odInvoke(Object target, Object[] arguments, MethodInformation 
                     methodInformation, Object[] originalArguments)

    FullyQualifiedErrorId : DotNetMethodException

    PositionMessage : 
                      At C:\windows\ccmcache\3w\AppDeployToolkit\AppDeployToolkitMa
                      in.ps1:5554 char:36
                      +         $result = $formWelcome.ShowDialog <<<< ()



    Error Inner Exception(s):
    -------------------------

    Message        : Showing a modal dialog box or form when the application is not
                      running in UserInteractive mode is not a valid operation. Spe
                     cify the ServiceNotification or DefaultDesktopOnly style to di
                     splay a notification from a service application.
    InnerException : 



    ... Show-DialogBox 11/6/2015 8:15:42 AM 8972 (0x230C)
    Friday, November 6, 2015 3:26 PM