none
Project server access over internet (Outside company's network) RRS feed

  • Question

  • Hi

    I want to make our project server available on the internet so that users can access the project server from outside nework and work on their projects. Any suggestions?

    Thank you

    Sunday, December 16, 2012 8:19 AM

All replies

  • First you need to have DNS  name registered with your internet provider. If you prefer you can obtain SSL certificate as well.

    Using SharePoint Central Administration, navigate to Alternet Access Mappings.  Select the web application on which PWA site has been provisioned. Add your internet address  under Internet zone. Do not include /PWA. Use only DNS name like http://mycompnay.com , save the settings. If you have SSL certificate enter the URL as https://mycompnay.com. Open IIS manager  and navigate to PWA web site. Right click and select edit bindings. Click on add and select https and provide SSL certificate. Apply the changes and you should able to access PWA site using http://mycompnay.com/pwa or https://mycompnay.com/pwa

    Similar thread

    http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/4288ae97-c4a7-4343-a482-00db34f0385f


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Sunday, December 16, 2012 4:02 PM
    Moderator
  • We are an ISP and we already have a domain registered, shabakah.com.sa. And the project server we have is shab-sp and I access it through http://shab-sp/pwa I want the server to be accessed through http://shab-sp.shabakah.com.sa/pwa

    I am using Sharepoint 2013 and Porject server 2013.

    Monday, December 17, 2012 6:28 AM
  • Use http://shab-sp.shabakah.com.sa for configuring AAM settings


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Monday, December 17, 2012 5:37 PM
    Moderator
  • I have configured the AAM and the PWA can now be opened with the URL, http://shab-sp.shabakah.com.sa/pwa using the local network but when I enter http://shab-sp.shabakah.com.sa it gives me a 404 error. And I cannot access it from outside network because I have assigned an internal IP address....

    And the second thing is the DNS is configured, but I am using local IP, should I assign a pulic IP or I can NAT?

    I feel stupid now...please help :(

    Thank you


    Tuesday, December 18, 2012 7:45 AM
  • You don't have to assign public IP, but you must configure NAT to redirect public IP request to your internal server IP


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Tuesday, December 18, 2012 4:49 PM
    Moderator

  • The below shows the AAM mapping. I can access this from the local network. I have configured NAT to redirect the public IP to the server. When I ping the server shab-sp.shabakah.com.sa from outside network it shows the server's local IP address so i am presuming the NAT is configured properly, but when I try to access the server from outside network it takes too long to respond and the request times out.

    Thursday, December 20, 2012 8:35 AM
  • When I access from outsife network using the public IP,

    Thursday, December 20, 2012 8:36 AM
  • First you should not use any other browser than IE.  Using non IE you will limited access to specific pages.

    Second purpose of NATing is to hide internal IP from outside world. Hence ping response should be blocked.

    For testing purpose add another entry in AAM with your IP address and try accessing http://212.102.0.41/pwa

    When I tried to access same url using IE , I am getting dialog box to enter user ID and password.

    But when I tried http://shab-sp.shabakah.com.sa/pwa result is page can not be displayed.

    I am not sure your how your NAT is configured, you can also assign public IP address to server and then try to access the PWA site.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Thursday, December 20, 2012 4:41 PM
    Moderator