locked
Incoming Email feature in SharePoint 2007 RRS feed

  • Question

  • This is how i setup the Incoming Email feature in SharePoint 2007:

    • Local AD domain: contoso.local
    • Email domain: contoso.com
    • IIS SMTP domain: spsvr.contoso.local (by default, IIS SMTP uses the server FQDN as the local domain)
    • IIS SMTP domain alias: sharepoint.contoso.com (this is the designated email domain for SharePoint libraries)

    A library is email enabled and has the following email addresses:

    • lib1@contoso.local
    • lib1@contoso.com
    • lib1@spsvr.contoso.local
    • lib1@sharepoint.contoso.com

    When sending emails with attachments to all four email addresses above, it successfully uploaded attachments to the library for all email addresses except lib1@sharepoint.contoso.com. The email did show up in the Drop folder and get picked up by SharePoint, but for some reason, it wouldn't upload the attachment to the library.

    It was working fine before. The biggest change on the network recently is Exchange 2007 was upgraded to Exchange 2010. Beside this change, I can't think of any other change might have affected the Incoming Email service. The strange thing is that it works for every email address except the designated email address.

    Please help. Any comment can lead me to the right direction to troubleshoot this. Thanks in advance.

     

    Thursday, May 26, 2011 3:36 PM

Answers

  • Did you try disabling then re-enable Incoming Email on the library?

     

    Allow this document library to receive e-mail? 

    No

    click OK

     

    Allow this document library to receive e-mail? 

    Yes

    click Ok

     

     

     


    http://www.sharepointed.com
    • Marked as answer by Leoyi Sun Wednesday, June 1, 2011 9:04 AM
    Thursday, May 26, 2011 8:00 PM
  • Hi,

    I suggest you to carry out the same.

    1. Enable verbose mode of logging and reproduce the issue to capture logs.

    2. If you do not get any breakthrough then try disabling or renabling the incoming email settings.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    • Marked as answer by Leoyi Sun Wednesday, June 1, 2011 9:04 AM
    Saturday, May 28, 2011 11:30 AM

All replies

  • Did you try disabling then re-enable Incoming Email on the library?

     

    Allow this document library to receive e-mail? 

    No

    click OK

     

    Allow this document library to receive e-mail? 

    Yes

    click Ok

     

     

     


    http://www.sharepointed.com
    • Marked as answer by Leoyi Sun Wednesday, June 1, 2011 9:04 AM
    Thursday, May 26, 2011 8:00 PM
  • I thought about giving it a try.

    I will post back here with result.

    Friday, May 27, 2011 8:02 PM
  • Hi,

    I suggest you to carry out the same.

    1. Enable verbose mode of logging and reproduce the issue to capture logs.

    2. If you do not get any breakthrough then try disabling or renabling the incoming email settings.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    • Marked as answer by Leoyi Sun Wednesday, June 1, 2011 9:04 AM
    Saturday, May 28, 2011 11:30 AM