locked
Registry permissions RRS feed

  • Question

  • I am a network user, the local machine administrator as well as the network administrator.

    I'm having some severe challenges in installing software. I'm getting error messages that I don't have permission to modify the registry.  Usually there is a specific 32 characterlong  registry key that is preseneted in an error dialog box.  Being familiar with REGEDIT I went deep into the registry and found the problem key to try and manually delete the keys (that worked once before).  Now the system reports back to me in an error message that I don't have permission to open the key.  Then I try to change the permissions and it won't let me assign new permissions or to modify permissions saying that I don't have sufficient authority.  This is maddening.

    Here's an example of a key that I can't delete or modify for Acrobat:

     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\84AC706F233C9204FAA893DB6F19C24D\68AB67CA3301004F7706000000000040

    There are six more like this to get iTunes to load. 

     

    This problem occurs regardless of how I log in.  I tried going into the user accounts to change permissions with the security tab and it won't let me change or add those either.... I also can't add any new users. 

     

    This is keeping me from running iTunes and now Adobe Acrobat Pro.  I really need some quick help!

    Tuesday, July 13, 2010 11:44 PM

All replies

  • Hello... (echo... echo...)

    Wednesday, July 28, 2010 8:15 PM
  • Similar issue.............Tried Safe Mode, Tried modding the permissions, problem persists.......Tried loging in as local and Domain admins no luck.............................thought for sure Tech Net would have an answer.......  
    Wednesday, February 9, 2011 8:34 PM
  • Same problem here.

    Maybe booting for a second Windows installation and opening the other installation's registry hive with regedit works, but I have yet to try this.

     

    Wednesday, March 16, 2011 12:15 PM
  • I solved that last December.

    I remember that  the keys just don't have any owner specified.

    Good luck

     

    Monday, March 28, 2011 2:00 AM
  • I figured out my problem so simple actually I was trying to delete the key from the top level, Once i drilled down and checked every sub-key I found two that the permissions not showing me as owner made the changes and checked every sub key changing any not showing me as owner and then I could delete the entries. "note I did check to change sub-keys from the top level when I took ownership but it still did not change all of the sub keys. I had to change some of them manually"
    Monday, May 16, 2011 3:50 PM