locked
Windows 7 and DirectX SDK causing 3D game errors RRS feed

  • Question

  • I'd been using Visual Studio 2008 Team Solutions for about a year or so and have been compiling my projects with no problems on Windows Vista Ultimate 64.  This past Monday I installed Windows 7 RC1.  I then grabbed the March 2009 release of DirectX SDK and used the web installer for Windows SDK.

    All of a sudden, none of my 3D games will run anymore.  I am getting this error:

    "Failed to initialize Direct3D! Make sure you have DirectX 9 installed, and are running a graphics card that supports Pixel Shader 1.1"

    I CAN compile my code...

    When I uninstall the DirectX SDK, I can magically run my games again, but I can no longer compile the code!

    I've tried using various versions of the DirectX SDK with the following results:
    November 2008 - Same problem
    August 2008 - Same problem
    August 2007 - Same problem
    November 2005 - Game runs, VS2008 won't compile (missing x3daudio.dll)

    It would be a HUGE pain in the ____ to install the SDK, compile, uninstall, test changes in game, rinse/repeat...  I do NOT have time to be messing around with BS like that...

    Any ideas?  Fixes??
    Saturday, August 29, 2009 2:08 AM

Answers

  • Hi,

    The most latest DirectX SDK is for Windows Vista. The possible reason is that the DirectX SDK 32bit for Windows Vista is compatible with Windows 7 but the 64bit one is not. We may need to wait for the new SDK.

    Meantime, I suggest that you run the Windows XP Mode RC in your Windows 7 as a workaround. 

    Windows XP Mode and Windows Virtual PC

    You may need to copy files from the Windows 7 computer to the Windows XP Mode. You just need to set the IP addresses of the Virtual PC and the Windows 7 computer into the same network section. Then share the files via network. You may install Direct SDK in the Windows XP Mode and debug programs in it.


    Arthur Xie - MSFT
    • Marked as answer by Novak Wu Monday, September 7, 2009 12:52 AM
    Friday, September 4, 2009 10:34 AM

All replies

  • Hi,

    Where did you get the DirectX 9? I suggest you to install DirectX End-User Runtime after DirectX SDK is installed.

    Note: DirectX End-User Runtime Web Installer cannot be uninstalled. Make sure that System Restore is enabled so you could restore if you do not want to keep  DirectX End-User Runtime Web Installer in the system.

    If the issue persists, I suspect that the DirectX SDK is not compatible for Windows 7. We may need to wait for the new versions of  DirectX End-User Runtime Web Installer and DirectX SDK.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Wednesday, September 2, 2009 1:50 AM
    • Unmarked as answer by Arthur Xie Friday, September 4, 2009 5:15 AM
    Monday, August 31, 2009 8:49 AM
  • I got DirectX from Microsoft.com...

    I also already tried installing the End-User Runtime (not web install) AFTER the SDK and still no go...  I even tried uninstalling everything while in Safe Mode, restart, and reinstall everything in Safe Mode... Still no go...

    I have an employee that has Windows 7, the DirectX SDK, and no problems at all.  He is running 32-bit whereas I am running 64-bit...  Near as we can tell, that's our only difference...
    Wednesday, September 2, 2009 1:56 AM
  • Hi,

    The most latest DirectX SDK is for Windows Vista. The possible reason is that the DirectX SDK 32bit for Windows Vista is compatible with Windows 7 but the 64bit one is not. We may need to wait for the new SDK.

    Meantime, I suggest that you run the Windows XP Mode RC in your Windows 7 as a workaround. 

    Windows XP Mode and Windows Virtual PC

    You may need to copy files from the Windows 7 computer to the Windows XP Mode. You just need to set the IP addresses of the Virtual PC and the Windows 7 computer into the same network section. Then share the files via network. You may install Direct SDK in the Windows XP Mode and debug programs in it.


    Arthur Xie - MSFT
    • Marked as answer by Novak Wu Monday, September 7, 2009 12:52 AM
    Friday, September 4, 2009 10:34 AM